Gas servo reversing
« on: August 13, 2016, 11:31:00 pm »
Hi there,

The servo on my throttle control is reversed. 2ms is for idle and 1ms is for wide open. I can check the "reversed" checkbox on the RC Input page of the config tab but on the output tab, the same checkbox is (the only one to be) greyed out. My remote control is an old Futaba Skysport with an FP-R127DF receiver, very reliable but not programmable. What can I do then ?

Thanks for your help,

f5soh

  • *****
  • 4529
    • LibrePilot
Re: Gas servo reversing
« Reply #1 on: August 13, 2016, 11:48:31 pm »
Hi,

Just to avoid arming issues that need Throttle stick to minimum, you should keep the input as expected and reverse the output dedicated to motor in Output tab.

Re: Gas servo reversing
« Reply #2 on: August 14, 2016, 12:51:37 am »
That's precisely the problem : the checkbox is greyed out in the output tab. Checking it is not possible nor allowed. Whether the checkbox in the input tab is checked or not has no influence on this (but reversing is done correctly).

When my throttle stick is to minimum, it generates a 2ms pulse (because of the "programming" switch on my transmitter). I want to keep it this way to be able to remove the autopilot without "reprogramming" the transmitter.

f5soh

  • *****
  • 4529
    • LibrePilot
Re: Gas servo reversing
« Reply #3 on: August 14, 2016, 01:10:36 am »
Sorry, Gcs assumes the Throttle output is electric so do not allow reversing and avoid safety issues.

You can try to change the output type manually in System tab > UAVOBrowser

Search for MixerSettings, find the "motor" and change to "servo"
Since you do not save/change settings in Vehicle tab the motor > servo change still.



Next you will be able to reverse output in Output tab.



Re: Gas servo reversing
« Reply #4 on: August 14, 2016, 01:46:24 am »
I had to restart the autopilot but it works great. Next step (tomorrow) is to pass through sensors calibration. Plus solve the arming problem : arming is not possible any more probably because I didn't use the "Transmitter Setup Wizard". Maybe a "Start Manual Calibration" will help...

Thanks