I am searching for a working UAV configuration
« on: May 08, 2016, 09:53:41 am »
Hello,
I am searching in this forum for a working UAV configuration file for my Revo with GPS.

I tried to configure my F450 quad copter with revo and opmini gps.
It works, also the oplink mini.

But if i change into another mode then stabilized1 by a switch, the copter will not fly.
It will flip and fly very unsteady.
I tried gps assist, altitude hold and more, it is always the same.
Only in the stabilized1 mode it flys smooth and easy.

If anyone has a working uav configuration file for a normal quad, i could save it to my copter and test it.



Has anyone here a configuration file to download it, or is here an separate section with working configurations?

Greetings from Germany
Jürgen

f5soh

  • *****
  • 4530
    • LibrePilot
Re: I am searching for a working UAV configuration
« Reply #1 on: May 08, 2016, 09:55:45 am »
Maybe better post your config file and understand whats wrong.

File > Export UAV settings and post file here.

Re: I am searching for a working UAV configuration
« Reply #2 on: May 08, 2016, 07:43:35 pm »
Maybe better post your config file and understand whats wrong.

File > Export UAV settings and post file here.

O.K, thank you
here is my file, my setup of the F450 with revo, gps and oplink

f5soh

  • *****
  • 4530
    • LibrePilot
Re: I am searching for a working UAV configuration
« Reply #3 on: May 08, 2016, 07:54:56 pm »
Stabilized1 and 2 are Attitude, the last is stabilized3 with Rate

You are using Fusion Algorithm  = Basic
No GPS configured
Mag and Accels not calibrated.

How do you want to fly other mode than Basic (complementary) ?
Assuming you can get a good (without alarm) onboard Mag while motors are running, you may need some readings:

https://librepilot.atlassian.net/wiki/display/LPDOC/Advanced+features
Please note the order, from the more easy to the more difficult.

Re: I am searching for a working UAV configuration
« Reply #4 on: May 10, 2016, 07:28:20 pm »
Stabilized1 and 2 are Attitude, the last is stabilized3 with Rate

You are using Fusion Algorithm  = Basic
No GPS configured
Mag and Accels not calibrated.

How do you want to fly other mode than Basic (complementary) ?
Assuming you can get a good (without alarm) onboard Mag while motors are running, you may need some readings:

https://librepilot.atlassian.net/wiki/display/LPDOC/Advanced+features
Please note the order, from the more easy to the more difficult.

I think i found it.
I calibrate all new gyro, board level, mag and accel and have the same alarms as before.
Atti, stab, mag and gps

Mmhh what to do? Always the same alarms?

So i looked in the gps settings and found no gps fix and no home location are saved.

Then i set the gps in the uav browser to autoconfigurestoreanddisable save it
and get a gps fix 3D.
After this i set homelocation on false and after some minutes it changed to true.

Now i have a homelocation an after calibrating mag the alarms changed to green.

Then i set the switch settings to gps assist and atritude to ins13gps.

After a little test fly i think it works. It was a little bit windy today so i wait for better weather.

Greetings from germany
Jürgen




« Last Edit: May 10, 2016, 07:31:56 pm by rubberducky »