Fatal Revo Mini lockups
« on: May 05, 2016, 03:39:55 am »
Hey guys, i've been very wary of flying my mini talon again after my experience a few weeks ago. To put it simply, the first time it happened, I was fiddling with the radio and when I went to move the sticks, absolutely nothing would happen, tried everything I could and finally gave up and pulled the power and reset which made it work fine after that.

Since I had no suspicions, I flew again, landed and just by random, I decided to wiggle the sticks again and sure enough it locked up again solid: the control surfaces stayed in the last position and the motor was going at the throttle level it happened to be at... I tried moving the servos by hand and they were stuck as if they were still receiving an input.

Not sure what to make of this, what could be the issue? I'm running four digital servos on my revo nano (Genuine openpilot hardware) with a ubec supplying 6v. Needless to say, I can't trust this thing right now...

Setup summary:
Openpilot Revo Nano
xuav mini talon with align ds410 servos
No GPS ( but I will install one later)
Servo outputs set to 333hz
Sbus from x8r for control
« Last Edit: May 10, 2016, 10:55:19 pm by VictorHuge »