Problème armement CC3D
« on: March 14, 2016, 02:30:28 pm »
Bonjour à tous :)

Comme vous l'avez peut être vu dans ma présentation de la semaine dernière, je suis tout nouveau sur le forum.

Je viens chercher de l'aide pour un problème d'armement moteurs sur une CC3D.

Alors voila l'histoire en détail :

Tout fonctionnait bien jusqu'a la dernière sortie que j'ai faite où subittement après un crash, il m'a été impossible de réarmer les moteurs. (J'ai configuré "yaw droite" pour armer).

En rentrant j'ai branché la carte sur GCS et je me suis appercu que la voie yaw ne repondait plus, pas étonnant donc que ca ne fonctionne pas.

Après le crash, je me suis dis qu'il y avait certainement un problème avec les branchements. J'ai tout vérifié, et j'ai refait la procédure complète avec l'assisant de configuration de GCS.

Cette fois ci, super, toutes les voies fonctionnent. Sauf que maintenant, il m'est impossible d'armer les moteurs..

J'ai vérifié que les valeurs du yaw max inscrites dans le logiciel étaient bien atteintes en bout de course du stick, aucun problème.

J'ai même essayé de passer un mode "toujours armé" mais même là, impossible de faire tourner les moteurs.

Je ne suis pas très expérimenté et voila qui me laisse perplexe.. Est il possible que la carte soit HS après un choc (même si celui ci n'a pas été très violent) ?

Merci de votre aide ! :)

Bonne journée

Vincent

f5soh

  • *****
  • 4548
    • LibrePilot
Re: Problème armement CC3D
« Reply #1 on: March 14, 2016, 02:55:27 pm »
Si tu peux poster ton fichier de config, peut-être as-tu changé qque chose qui coince maintenant.

Fichier > Exporter paramètres UAV

Re: Problème armement CC3D
« Reply #2 on: March 14, 2016, 06:22:37 pm »
Bonsoir,

Merci de ta réponse !

Je poste ça dès que possible :)

Je suis étudiant et je n'ai pas ma machine avec moi donc ce sera certainement samedi alors... à samedi !

Bonne soirée

Vincent

Re: Problème armement CC3D
« Reply #3 on: March 19, 2016, 12:15:39 pm »
Bonjour,

Voici mon fichier config :)

Merci et bonne journée
Vincent

<!DOCTYPE UAVObjects>
<uavobjects>
    <version>
        <hardware revision="2" serial="55ff6f065088515318152587" type="4"/>
        <firmware tag="15.09" uavo="85efdd63" date="20151021 19:14" hash="c3f2fd0b"/>
        <gcs tag="15.09" uavo="85efdd63" date="20151021 19:14" hash="c3f2fd0b"/>
    </version>
    <settings>
        <object name="AccelGyroSettings" id="0x1262B2D0">
            <field values="0,0,9.81" name="accel_bias"/>
            <field values="1,1,1" name="accel_scale"/>
            <field values="0,0,0" name="accel_temp_coeff"/>
            <field values="0,0,0" name="gyro_bias"/>
            <field values="1,1,1" name="gyro_scale"/>
            <field values="0,0,0,0,0,0" name="gyro_temp_coeff"/>
            <field values="0,0" name="temp_calibrated_extent"/>
        </object>
        <object name="ActuatorSettings" id="0xD2AD60A2">
            <field values="490,490,50,50,50,50" name="BankUpdateFreq"/>
            <field values="1900,1900,1900,1900,1000,1000,1000,1000,1000,1000,1000,1000" name="ChannelMax"/>
            <field values="1118,1118,1118,1118,1000,1000,1000,1000,1000,1000,1000,1000" name="ChannelNeutral"/>
            <field values="1000,1000,1000,1000,1000,1000,1000,1000,1000,1000,1000,1000" name="ChannelMin"/>
            <field values="PWM,PWM,PWM,PWM,PWM,PWM" name="BankMode"/>
            <field values="PWM,PWM,PWM,PWM,PWM,PWM,PWM,PWM,PWM,PWM,PWM,PWM" name="ChannelType"/>
            <field values="0,1,2,3,4,5,6,7,8,9,10,11" name="ChannelAddr"/>
            <field values="FALSE" name="MotorsSpinWhileArmed"/>
            <field values="FALSE,FALSE,FALSE" name="LowThrottleZeroAxis"/>
        </object>
        <object name="AirspeedSettings" id="0x69F4AD7A">
            <field values="1" name="Scale"/>
            <field values="0.5" name="IMUBasedEstimationLowPassPeriod1"/>
            <field values="10" name="IMUBasedEstimationLowPassPeriod2"/>
            <field values="0" name="ZeroPoint"/>
            <field values="100" name="SamplePeriod"/>
            <field values="None" name="AirspeedSensorType"/>
        </object>
        <object name="AltitudeFilterSettings" id="0xE611042C">
            <field values="0.04" name="AccelLowPassKp"/>
            <field values="0.0005" name="AccelDriftKi"/>
            <field values="0.2" name="InitializationAccelDriftKi"/>
            <field values="0.04" name="BaroKp"/>
        </object>
        <object name="AltitudeHoldSettings" id="0x6E3464C4">
            <field values="5" name="ThrustRate"/>
            <field values="0.2,0.5,0.9" name="ThrustLimits"/>
            <field values="0.7" name="VerticalPosP"/>
            <field values="0.3,1,0.0001,0.9" name="VerticalVelPID"/>
            <field values="True" name="CutThrustWhenZero"/>
            <field values="128" name="ThrustExp"/>
        </object>
        <object name="AttitudeSettings" id="0x448954B8">
            <field values="0,0,0" name="BoardRotation"/>
            <field values="0,0" name="BoardLevelTrim"/>
            <field values="0.05" name="AccelKp"/>
            <field values="0.0001" name="AccelKi"/>
            <field values="1e-06" name="MagKi"/>
            <field values="0.01" name="MagKp"/>
            <field values="0.1" name="AccelTau"/>
            <field values="1e-06" name="YawBiasRate"/>
            <field values="TRUE" name="ZeroDuringArming"/>
            <field values="TRUE" name="BiasCorrectGyro"/>
            <field values="NORMAL" name="TrimFlight"/>
        </object>
        <object name="AuxMagSettings" id="0x42F462A">
            <field values="0,0,0" name="mag_bias"/>
            <field values="1,0,0,0,1,0,0,0,1" name="mag_transform"/>
            <field values="0" name="MagBiasNullingRate"/>
            <field values="0" name="Orientation"/>
            <field values="GPSV9" name="Type"/>
            <field values="Both" name="Usage"/>
        </object>
        <object name="CameraStabSettings" id="0xEA58E53A">
            <field values="1" name="MaxAxisLockRate"/>
            <field values="500" name="MaxAccel"/>
            <field values="None,None,None" name="Input"/>
            <field values="20,20,20" name="InputRange"/>
            <field values="50,50,50" name="InputRate"/>
            <field values="Attitude,Attitude,Attitude" name="StabilizationMode"/>
            <field values="20,20,20" name="OutputRange"/>
            <field values="0,0,0" name="ResponseTime"/>
            <field values="Generic" name="GimbalType"/>
            <field values="0,0,0" name="FeedForward"/>
            <field values="5,5,5" name="AccelTime"/>
            <field values="5,5,5" name="DecelTime"/>
            <field values="FALSE" name="Servo1PitchReverse"/>
            <field values="FALSE" name="Servo2PitchReverse"/>
        </object>
        <object name="DebugLogSettings" id="0x5E5903CC">
            <field values="Disabled" name="LoggingEnabled"/>
        </object>
        <object name="EKFConfiguration" id="0x5E91213C">
            <field values="10,10,10,1,1,1,0.007,0.007,0.007,0.007,1e-06,1e-06,1e-06" name="P"/>
            <field values="0.01,0.01,0.01,0.01,0.01,0.01,1e-06,1e-06,1e-06" name="Q"/>
            <field values="1,1,1e+06,0.001,0.001,0.001,10,10,10,0.01" name="R"/>
            <field values="10,1,1000" name="FakeR"/>
        </object>
        <object name="FaultSettings" id="0x2778BA3C">
            <field values="NoFault" name="ActivateFault"/>
        </object>
        <object name="FixedWingPathFollowerSettings" id="0x38AD8B0A">
            <field values="20" name="HorizontalVelMax"/>
            <field values="10" name="HorizontalVelMin"/>
            <field values="10" name="VerticalVelMax"/>
            <field values="3" name="CourseFeedForward"/>
            <field values="20" name="ReverseCourseOverlap"/>
            <field values="0.2" name="HorizontalPosP"/>
            <field values="0.4" name="VerticalPosP"/>
            <field values="0.2,0,0" name="CoursePI"/>
            <field values="2.5,0.25,10" name="SpeedPI"/>
            <field values="5,10" name="VerticalToPitchCrossFeed"/>
            <field values="0.2,1" name="AirspeedToPowerCrossFeed"/>
            <field values="0.01,0.05,0.5" name="PowerPI"/>
            <field values="-45,0,45" name="RollLimit"/>
            <field values="-10,5,20" name="PitchLimit"/>
            <field values="0.1,0.5,0.9" name="ThrustLimit"/>
            <field values="90,1,0.5,1.5,1,1,0,1" name="Safetymargins"/>
            <field values="100" name="UpdatePeriod"/>
        </object>
        <object name="FlightBatterySettings" id="0x56EBA4CC">
            <field values="2200" name="Capacity"/>
            <field values="3.4,3.1" name="CellVoltageThresholds"/>
            <field values="1,1,0,0" name="SensorCalibrations"/>
            <field values="LiPo" name="Type"/>
            <field values="0" name="NbCells"/>
            <field values="false" name="ResetConsumedEnergy"/>
        </object>
        <object name="FlightModeSettings" id="0xCC579770">
            <field values="10" name="ReturnToBaseAltitudeOffset"/>
            <field values="0.6" name="LandingVelocity"/>
            <field values="0.6" name="AutoTakeOffVelocity"/>
            <field values="2.5" name="AutoTakeOffHeight"/>
            <field values="30,15" name="PositionHoldOffset"/>
            <field values="0.98" name="VarioControlLowPassAlpha"/>
            <field values="30000" name="ArmedTimeout"/>
            <field values="1000" name="ArmingSequenceTime"/>
            <field values="1000" name="DisarmingSequenceTime"/>
            <field values="Yaw Right" name="Arming"/>
            <field values="Attitude,Attitude,AxisLock,Manual" name="Stabilization1Settings"/>
            <field values="Attitude,Attitude,Rate,Manual" name="Stabilization2Settings"/>
            <field values="Rate,Rate,Rate,Manual" name="Stabilization3Settings"/>
            <field values="Attitude,Attitude,AxisLock,CruiseControl" name="Stabilization4Settings"/>
            <field values="Attitude,Attitude,Rate,CruiseControl" name="Stabilization5Settings"/>
            <field values="Rate,Rate,Rate,Manual" name="Stabilization6Settings"/>
            <field values="Stabilized1,Stabilized2,Stabilized3,Stabilized4,Stabilized5,Stabilized6" name="FlightModePosition"/>
            <field values="FALSE" name="AlwaysStabilizeWhenArmed"/>
            <field values="FALSE" name="DisableSanityChecks"/>
            <field values="Hold" name="ReturnToBaseNextCommand"/>
        </object>
        <object name="FlightPlanSettings" id="0x92E9FF76">
            <field values="0" name="Test"/>
        </object>
        <object name="GPSSettings" id="0xF9717C34">
            <field values="3.5" name="MaxPDOP"/>
            <field values="UBX" name="DataProtocol"/>
            <field values="7" name="MinSatellites"/>
            <field values="AutoBaudAndConfigure" name="UbxAutoConfig"/>
            <field values="5" name="UbxRate"/>
            <field values="Airborne1G" name="UbxDynamicModel"/>
            <field values="Ranging" name="UbxSBASMode"/>
            <field values="3" name="UbxSBASChannelsUsed"/>
            <field values="AutoScan" name="UbxSBASSats"/>
            <field values="Default" name="UbxGNSSMode"/>
        </object>
        <object name="GroundPathFollowerSettings" id="0xCD54334C">
            <field values="2" name="HorizontalVelMax"/>
            <field values="0" name="HorizontalVelMin"/>
            <field values="3" name="CourseFeedForward"/>
            <field values="0.1" name="VelocityFeedForward"/>
            <field values="0.2" name="HorizontalPosP"/>
            <field values="0.1,0.1,0.001,0.8" name="SpeedPI"/>
            <field values="-0.3,0.15,0.3" name="ThrustLimit"/>
            <field values="100" name="UpdatePeriod"/>
        </object>
        <object name="HomeLocation" id="0x6185DC6E">
            <field values="0" name="Latitude"/>
            <field values="0" name="Longitude"/>
            <field values="0" name="Altitude"/>
            <field values="0,0,0" name="Be"/>
            <field values="9.81" name="g_e"/>
            <field values="FALSE" name="Set"/>
        </object>
        <object name="HwSettings" id="0xD4DB6008">
            <field values="PWM+NoOneShot" name="CC_RcvrPort"/>
            <field values="Telemetry" name="CC_MainPort"/>
            <field values="Disabled" name="CC_FlexiPort"/>
            <field values="PWM" name="RV_RcvrPort"/>
            <field values="Disabled" name="RV_AuxPort"/>
            <field values="Disabled" name="RV_AuxSBusPort"/>
            <field values="Disabled" name="RV_FlexiPort"/>
            <field values="Telemetry" name="RV_TelemetryPort"/>
            <field values="GPS" name="RV_GPSPort"/>
            <field values="PWM" name="RM_RcvrPort"/>
            <field values="Disabled" name="RM_MainPort"/>
            <field values="Disabled" name="RM_FlexiPort"/>
            <field values="57600" name="TelemetrySpeed"/>
            <field values="57600" name="GPSSpeed"/>
            <field values="57600" name="ComUsbBridgeSpeed"/>
            <field values="USBTelemetry" name="USB_HIDPort"/>
            <field values="Disabled" name="USB_VCPPort"/>
            <field values="Disabled,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled" name="OptionalModules"/>
            <field values="Disabled,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled" name="ADCRouting"/>
            <field values="0" name="DSMxBind"/>
            <field values="Disabled" name="WS2811LED_Out"/>
        </object>
        <object name="ManualControlSettings" id="0x72A1176C">
            <field values="-1,0,0,0,0,0,0,0,0" name="FailsafeChannel"/>
            <field values="991,986,2009,985,986,0,0,0,0,0" name="ChannelMin"/>
            <field values="1031,1497,1492,1496,1497,0,0,0,0,0" name="ChannelNeutral"/>
            <field values="2007,2008,985,2008,2008,0,0,0,0,0" name="ChannelMax"/>
            <field values="0,0,0,0,0,0,0,0" name="ResponseTime"/>
            <field values="PWM,PWM,PWM,PWM,PWM,None,None,None,None,None" name="ChannelGroups"/>
            <field values="1,3,4,2,6,0,0,0,0,0" name="ChannelNumber"/>
            <field values="2" name="Deadband"/>
            <field values="8" name="DeadbandAssistedControl"/>
            <field values="3" name="FlightModeNumber"/>
            <field values="-1" name="FailsafeFlightModeSwitchPosition"/>
        </object>
        <object name="MixerSettings" id="0x810D3A5E">
            <field values="0,0.225,0.45,0.675,0.9" name="ThrottleCurve1"/>
            <field values="0,0.225,0.45,0.675,0.9" name="ThrottleCurve2"/>
            <field values="50" name="MixerValueRoll"/>
            <field values="50" name="MixerValuePitch"/>
            <field values="50" name="MixerValueYaw"/>
            <field values="0" name="RollDifferential"/>
            <field values="0" name="FirstRollServo"/>
            <field values="Throttle" name="Curve2Source"/>
            <field values="Motor" name="Mixer1Type"/>
            <field values="127,0,64,64,-64" name="Mixer1Vector"/>
            <field values="Motor" name="Mixer2Type"/>
            <field values="127,0,-64,64,64" name="Mixer2Vector"/>
            <field values="Motor" name="Mixer3Type"/>
            <field values="127,0,-64,-64,-64" name="Mixer3Vector"/>
            <field values="Motor" name="Mixer4Type"/>
            <field values="127,0,64,-64,64" name="Mixer4Vector"/>
            <field values="Disabled" name="Mixer5Type"/>
            <field values="0,0,0,0,0" name="Mixer5Vector"/>
            <field values="Disabled" name="Mixer6Type"/>
            <field values="0,0,0,0,0" name="Mixer6Vector"/>
            <field values="Disabled" name="Mixer7Type"/>


Re: Problème armement CC3D
« Reply #4 on: March 19, 2016, 12:17:02 pm »
Et voici la suite.. Désolé je ne savais pas comment faire pour prendre moins de place.

Merci de votre aide :)

            <field values="0,0,0,0,0" name="Mixer7Vector"/>
            <field values="Disabled" name="Mixer8Type"/>
            <field values="0,0,0,0,0" name="Mixer8Vector"/>
            <field values="Disabled" name="Mixer9Type"/>
            <field values="0,0,0,0,0" name="Mixer9Vector"/>
            <field values="Disabled" name="Mixer10Type"/>
            <field values="0,0,0,0,0" name="Mixer10Vector"/>
            <field values="Disabled" name="Mixer11Type"/>
            <field values="0,0,0,0,0" name="Mixer11Vector"/>
            <field values="Disabled" name="Mixer12Type"/>
            <field values="0,0,0,0,0" name="Mixer12Vector"/>
        </object>
        <object name="MPUGyroAccelSettings" id="0x7E2826C8">
            <field values="Scale_2000" name="GyroScale"/>
            <field values="Scale_8g" name="AccelScale"/>
            <field values="Lowpass_188_Hz" name="FilterSetting"/>
        </object>
        <object name="OPLinkSettings" id="0x8885F812">
            <field values="0" name="CoordID"/>
            <field values="FALSE" name="Coordinator"/>
            <field values="FALSE" name="OneWay"/>
            <field values="FALSE" name="PPM"/>
            <field values="FALSE" name="PPMOnly"/>
            <field values="Disabled" name="MainPort"/>
            <field values="Disabled" name="FlexiPort"/>
            <field values="Disabled" name="VCPPort"/>
            <field values="38400" name="ComSpeed"/>
            <field values="0" name="MaxRFPower"/>
            <field values="0" name="MinChannel"/>
            <field values="250" name="MaxChannel"/>
        </object>
        <object name="OsdSettings" id="0xDCBBA81A">
            <field values="168,135" name="AttitudeSetup"/>
            <field values="10,250" name="TimeSetup"/>
            <field values="316,210" name="BatterySetup"/>
            <field values="2,145" name="SpeedSetup"/>
            <field values="2,145" name="AltitudeSetup"/>
            <field values="168,240" name="HeadingSetup"/>
            <field values="Enabled" name="Attitude"/>
            <field values="Enabled" name="Time"/>
            <field values="Enabled" name="Battery"/>
            <field values="Enabled" name="Speed"/>
            <field values="Enabled" name="Altitude"/>
            <field values="Enabled" name="Heading"/>
            <field values="0" name="Screen"/>
            <field values="4" name="White"/>
            <field values="1" name="Black"/>
            <field values="GPS" name="AltitudeSource"/>
        </object>
        <object name="OveroSyncSettings" id="0xA1ABC278">
            <field values="Armed" name="LogOn"/>
        </object>
        <object name="PoiLearnSettings" id="0x9E22E820">
            <field values="None" name="Input"/>
        </object>
        <object name="RevoCalibration" id="0xA3633042">
            <field values="0,0,0" name="mag_bias"/>
            <field values="1,0,0,0,1,0,0,0,1" name="mag_transform"/>
            <field values="0" name="MagBiasNullingRate"/>
            <field values="FALSE" name="BiasCorrectedRaw"/>
        </object>
        <object name="RevoSettings" id="0xC456EB9A">
            <field values="0.999334" name="BaroGPSOffsetCorrectionAlpha"/>
            <field values="0.05,0.15" name="MagnetometerMaxDeviation"/>
            <field values="0,0,0,0" name="BaroTempCorrectionPolynomial"/>
            <field values="0,0" name="BaroTempCorrectionExtent"/>
            <field values="0.999" name="VelocityPostProcessingLowPassAlpha"/>
            <field values="Basic (Complementary)" name="FusionAlgorithm"/>
        </object>
        <object name="StabilizationSettings" id="0x73603180">
            <field values="0.5,0.5,0.5" name="VbarSensitivity"/>
            <field values="0.005,0.002" name="VbarRollPI"/>
            <field values="0.005,0.002" name="VbarPitchPI"/>
            <field values="0.005,0.002" name="VbarYawPI"/>
            <field values="0.5" name="VbarTau"/>
            <field values="0.004" name="GyroTau"/>
            <field values="1" name="DerivativeGamma"/>
            <field values="2.5" name="AxisLockKp"/>
            <field values="0.1" name="WeakLevelingKp"/>
            <field values="3" name="CruiseControlMaxPowerFactor"/>
            <field values="100" name="CruiseControlPowerTrim"/>
            <field values="0.25" name="CruiseControlPowerDelayComp"/>
            <field values="0" name="ScaleToAirspeed"/>
            <field values="0.05,3" name="ScaleToAirspeedLimits"/>
            <field values="Bank1,Bank1,Bank1,Bank1,Bank1,Bank1" name="FlightModeMap"/>
            <field values="30" name="VbarGyroSuppress"/>
            <field values="FALSE" name="VbarPiroComp"/>
            <field values="10" name="VbarMaxAngle"/>
            <field values="20" name="DerivativeCutoff"/>
            <field values="30" name="MaxAxisLock"/>
            <field values="2" name="MaxAxisLockRate"/>
            <field values="5" name="MaxWeakLevelingRate"/>
            <field values="80" name="RattitudeModeTransition"/>
            <field values="5" name="CruiseControlMinThrust"/>
            <field values="90" name="CruiseControlMaxThrust"/>
            <field values="105" name="CruiseControlMaxAngle"/>
            <field values="FALSE,FALSE,FALSE,FALSE,FALSE,FALSE" name="CruiseControlFlightModeSwitchPosEnable"/>
            <field values="Unreversed" name="CruiseControlInvertedThrustReversing"/>
            <field values="Zero" name="CruiseControlInvertedPowerOutput"/>
            <field values="TRUE" name="LowThrottleZeroIntegral"/>
            <field values="None,None,None,None,None,None" name="FlightModeAssistMap"/>
        </object>
        <object name="StabilizationSettingsBank1" id="0xF03FDBA2">
            <field values="0.0027,0.007,4e-05,0.3" name="RollRatePID"/>
            <field values="0.0033,0.0125,6e-05,0.3" name="PitchRatePID"/>
            <field values="0.00755,0.0115,5e-05,0.3" name="YawRatePID"/>
            <field values="3,0,50" name="RollPI"/>
            <field values="3.4,0,50" name="PitchPI"/>
            <field values="2.5,0,50" name="YawPI"/>
            <field values="420,400,310" name="ManualRate"/>
            <field values="475,475,360" name="MaximumRate"/>
            <field values="80" name="RollMax"/>
            <field values="80" name="PitchMax"/>
            <field values="35" name="YawMax"/>
            <field values="12,12,14" name="StickExpo"/>
            <field values="40,40,40" name="AcroInsanityFactor"/>
            <field values="FALSE" name="EnablePiroComp"/>
            <field values="TRUE" name="EnableThrustPIDScaling"/>
            <field values="18,9,0,-10,-20" name="ThrustPIDScaleCurve"/>
            <field values="ActuatorDesiredThrust" name="ThrustPIDScaleSource"/>
            <field values="PD" name="ThrustPIDScaleTarget"/>
            <field values="Roll Pitch" name="ThrustPIDScaleAxes"/>
        </object>
        <object name="StabilizationSettingsBank2" id="0x2B10CA1C">
            <field values="0.0033,0.0076,3.6e-05,0.3" name="RollRatePID"/>
            <field values="0.0045,0.0094,4.5e-05,0.3" name="PitchRatePID"/>
            <field values="0.0086,0.0143,5e-05,0.3" name="YawRatePID"/>
            <field values="3,0,50" name="RollPI"/>
            <field values="3.4,0,50" name="PitchPI"/>
            <field values="2.5,0,50" name="YawPI"/>
            <field values="400,400,220" name="ManualRate"/>
            <field values="400,400,300" name="MaximumRate"/>
            <field values="55" name="RollMax"/>
            <field values="55" name="PitchMax"/>
            <field values="35" name="YawMax"/>
            <field values="18,18,-8" name="StickExpo"/>
            <field values="40,40,40" name="AcroInsanityFactor"/>
            <field values="FALSE" name="EnablePiroComp"/>
            <field values="TRUE" name="EnableThrustPIDScaling"/>
            <field values="19,8,0,-8,-18" name="ThrustPIDScaleCurve"/>
            <field values="ActuatorDesiredThrust" name="ThrustPIDScaleSource"/>
            <field values="PD" name="ThrustPIDScaleTarget"/>
            <field values="Roll Pitch" name="ThrustPIDScaleAxes"/>
        </object>
        <object name="StabilizationSettingsBank3" id="0xA86BDC0A">
            <field values="0.0025,0.004,2e-05,0.3" name="RollRatePID"/>
            <field values="0.0025,0.004,2e-05,0.3" name="PitchRatePID"/>
            <field values="0.0062,0.01,5e-05,0.3" name="YawRatePID"/>
            <field values="2.5,0,50" name="RollPI"/>
            <field values="2.5,0,50" name="PitchPI"/>
            <field values="2.5,0,50" name="YawPI"/>
            <field values="220,220,220" name="ManualRate"/>
            <field values="300,300,300" name="MaximumRate"/>
            <field values="55" name="RollMax"/>
            <field values="55" name="PitchMax"/>
            <field values="35" name="YawMax"/>
            <field values="0,0,0" name="StickExpo"/>
            <field values="40,40,40" name="AcroInsanityFactor"/>
            <field values="TRUE" name="EnablePiroComp"/>
            <field values="FALSE" name="EnableThrustPIDScaling"/>
            <field values="30,15,0,-15,-30" name="ThrustPIDScaleCurve"/>
            <field values="ActuatorDesiredThrust" name="ThrustPIDScaleSource"/>
            <field values="PID" name="ThrustPIDScaleTarget"/>
            <field values="Roll Pitch" name="ThrustPIDScaleAxes"/>
        </object>
        <object name="SystemSettings" id="0xD9D093B8">
            <field values="874577920,0,0,0" name="GUIConfigData"/>
            <field values="30" name="AirSpeedMax"/>
            <field values="10" name="AirSpeedMin"/>
            <field values="QuadX" name="AirframeType"/>
            <field values="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0" name="VehicleName"/>
            <field values="Throttle" name="ThrustControl"/>
        </object>
        <object name="TakeOffLocation" id="0xD292FDCC">
            <field values="0" name="North"/>
            <field values="0" name="East"/>
            <field values="0" name="Down"/>
            <field values="ArmingLocation" name="Mode"/>
            <field values="Invalid" name="Status"/>
        </object>
        <object name="TxPIDSettings" id="0x8815E7D4">
            <field values="0.2,0.8" name="ThrottleRange"/>
            <field values="0,0,0" name="MinPID"/>
            <field values="0,0,0" name="MaxPID"/>
            <field values="3,0.0135" name="EasyTunePitchRollRateFactors"/>
            <field values="1.5,1.9,0.0085" name="EasyTuneYawRateFactors"/>
            <field values="When Armed" name="UpdateMode"/>
            <field values="Bank1" name="BankNumber"/>
            <field values="Throttle,Accessory0,Accessory1" name="Inputs"/>
            <field values="Disabled,Disabled,Disabled" name="PIDs"/>
            <field values="TRUE" name="EasyTuneRatePIDRecalculateYaw"/>
        </object>
        <object name="VtolPathFollowerSettings" id="0x7B394C76">
            <field values="10" name="HorizontalVelMax"/>
            <field values="4" name="VerticalVelMax"/>
            <field values="1" name="CourseFeedForward"/>
            <field values="0.25" name="HorizontalPosP"/>
            <field values="0.3" name="VerticalPosP"/>
            <field values="8,0.5,0.001,0.95" name="HorizontalVelPID"/>
            <field values="0.15,0.25,0.005,0.95" name="VerticalVelPID"/>
            <field values="0.2,0.5,0.9" name="ThrustLimits"/>
            <field values="2" name="VelocityFeedforward"/>
            <field values="10" name="FlyawayEmergencyFallbackTriggerTime"/>
            <field values="0,-20" name="EmergencyFallbackAttitude"/>
            <field values="2,30" name="EmergencyFallbackYawRate"/>
            <field values="25" name="MaxRollPitch"/>
            <field values="2.5" name="BrakeRate"/>
            <field values="25" name="BrakeMaxPitch"/>
            <field values="18,0,0.001,0.95" name="BrakeHorizontalVelPID"/>
            <field values="0" name="BrakeVelocityFeedforward"/>
            <field values="0.42,3,0.02,0.95" name="LandVerticalVelPID"/>
            <field values="0.42,3,0.02,0.95" name="AutoTakeoffVerticalVelPID"/>
            <field values="20" name="VelocityRoamMaxRollPitch"/>
            <field values="12,0.5,0.001,0.95" name="VelocityRoamHorizontalVelPID"/>
            <field values="20" name="UpdatePeriod"/>
            <field values="FixedWing" name="TreatCustomCraftAs"/>
            <field values="auto" name="ThrustControl"/>
            <field values="manual" name="YawControl"/>
            <field values="enabled" name="FlyawayEmergencyFallback"/>
        </object>
    </settings>
</uavobjects>

Re: Problème armement CC3D
« Reply #5 on: March 21, 2016, 03:26:26 pm »
Bonjour bonjour ! :)

J'ai encore essayé de refaire la procédure complète de configuration de ma CC3D et toujours aucun résultat, je commence a désespérer un peu ^^
Ce que je trouve bizzare c'est que même le mode "toujours armé" ne fonctionne pas..

Est ce que vous avez une idée ?

Merci et bonne journée
Vincent

f5soh

  • *****
  • 4548
    • LibrePilot
Re: Problème armement CC3D
« Reply #6 on: March 21, 2016, 04:30:16 pm »
Ouille...
j'avais zappé.

Rien de spécial dans ta config qui pourrait empêcher d'armer.
Bien vérifier que tous tes manches sont bien affectés en refaisant l'assistant radio.

Tu veux dire qu'en mettant "toujours armé" la carte n'affiche pas "Armed" dans le PFD ?
Aucune alarme ?


Re: Problème armement CC3D
« Reply #7 on: March 21, 2016, 08:21:57 pm »
Merci de ta réponse :)

J'ai refais l'assistant radio, mes voies sont bien attribuées ainsi que l'inter 3 positions.

Je ne sais pas ou est le PFD mais lorsque je met "always armed", le logiciel dit "Armed" et l'état passe à "armé" dans l'onglet flighdata. Par contre, lorsque je clique sur "enregistrer" en bas a droite, y'a la petite croix rouge qui apparaît et disparaît aussitôt a gauche du bouton. Les paramètres ne sont donc pas pris en compte ?

Lorsque je met "yaw right" dans les paramètres d'armement et que je clique sur "enregistrer", j'ai un petit "tick" vert qui apparait, pour dire que c'est sauvegardé je suppose.

Dans les deux cas, impossible d'armer la carte.

Est ce que tu as une idée ? Est ce que c'est un problème connu ?

Merci de ton aide

Bonne soirée ! :)

Re: Problème armement CC3D
« Reply #8 on: March 21, 2016, 10:21:10 pm »
Salut c'est moi qui t'a envoyer ici!!!
 Un truc qui vient à l'esprit ,dans tes modes de vol inter 3 positions tu as quoi? Un acro+?

f5soh

  • *****
  • 4548
    • LibrePilot
Re: Problème armement CC3D
« Reply #9 on: March 21, 2016, 10:26:14 pm »
Si il dit "Armed" la carte est armée !
Une fois que tu as mis à "Always armed" tu ne peux plus faire de modifs, c'est normal.

Si tu as mis "Yaw Right" dans le paramètre d'armement tu dois pouvoir armer la carte avec ta radio.
Gaz à zéro puis Yaw à droite, puis à gauche pour désarmer.

Le récepteur doit être alimenté, l'usb ne suffit pas.

Re: Problème armement CC3D
« Reply #10 on: March 21, 2016, 10:44:31 pm »
Juste un truc qui met arriver la semaine dernière :

Sur l'inter 3 position, j'ai mis une position  acro+ pour testé puis sauvegardé et là comme toi impossible d'armée. J'ai cherché pendant des plomb je croyais à la mort de la carte

Puis chercher, chercher puis trouver dans l'inter acro+ j'ai mis cruise control il faut mettre MANUEL pour que les moteurs s'arme.

Une autre fois , pareil même souci impossible d'armer. Parce que j'ai poussé mes trim trop bas

Re: Problème armement CC3D
« Reply #11 on: March 22, 2016, 03:20:52 pm »
Bonjour,

Merci de vos réponses ! :)

Il dit bien "Armed" mais rien... Voila exactement les procédures que j'ai effectuées :

J'ai branché l'USB + la batterie, j'ai sélectionné dans les paramètres d'armement "always armed", a ce moment la, j'entend "Armed". J'enregistre avec le bouton en bas a droite, je débranche l'USB et la batterie. J'attend 30s, je rebranche la batterie et j'attend 10s. Ensuite, rien. Même chose quand je sélectionne "yaw right".

Au branchement de la batterie, la led bleu de la carte clignote rapidement puis après quelques secondes (4-5) elle se met a clignoter plus doucement. La led verte est fixe.

Pour les modes de vol j'ai mis : 1) Attitude, attitude, manual
2) Rattitude, rattitude, manual
3) Accro +, Accro +, Manual

J'ai essayé de mettre 3 fois attitude, rattitude, accro, etc...

Voila une capture d'écran de l'onglet mode de vol (au cas ou je fasse une boulette ^^' )

http://image.noelshack.com/fichiers/2016/12/1458656338-mode-de-vol.jpg


Vous en pensez quoi ? C'est possible qu'un crash cause ce genre de panne ?

Je crois que je vais recommander une autre FC :(

Merci de votre aide, bonne aprem :)

Vincent

f5soh

  • *****
  • 4548
    • LibrePilot
Re: Problème armement CC3D
« Reply #12 on: March 22, 2016, 09:51:25 pm »
Ah... vu !
Dans les modes de stabilization, Yaw doit être en rate ou AxisLock, pas Manual.


Re: Problème armement CC3D
« Reply #13 on: March 23, 2016, 07:35:19 am »
Bonjour,

J'ai mis rate partout sur Yaw et ça ne marche pas..

Erf :(

Re: Problème armement CC3D
« Reply #14 on: April 04, 2016, 11:01:21 pm »
Bonjour à tous :)

J'ai finalement résolu mon problème en changeant de carte CC3D.

Cette fois ci j'arrive a armer les moteurs !

J'aurai besoin d'aide pour résoudre un problème que j'avais déjà sur mon ancienne carte.
Lorsque je pousse le manche des gaz, par exemple a 10% et que je cesse de le toucher, les moteurs montent progressivement (mais assez rapidement quand même) en régime jusqu’à fond ou presque.

Je précise que je suis en mode "manuel" dans la partie "poussée". J'ai lu sur un autre forum qu'il ne fallait pas utiliser ce mode mais si je passe en cruise control, il m'est impossible d'armer la carte..

Si quelqu'un a une idée :)

Merci et bonne soirée

Vincent