kknapp

  • *
  • 6
Help...elevon moves when throttle is raised.
« on: February 21, 2016, 05:50:14 pm »
Hello I am hoping someone may be able to help me with this issues.  I have a stock FX-61 Phantom with a Turnigy 9x that I am trying to install a cc3d atom into.  Once I arm the motor and start to apply throttle the elevon plugged in to port 2 starts to raise, even at the lowest throttle setting the elevon with go to full up.

I have wired it up according to the directions and have double checked several times.  I have tried reflashing the device multiple times but I alway wind up with this issue.

Any help would be great

f5soh

  • *****
  • 4529
    • LibrePilot
Re: Help...elevon moves when throttle is raised.
« Reply #1 on: February 21, 2016, 06:48:16 pm »
Hi

The opposite elevon do nothing at same time ?

kknapp

  • *
  • 6
Re: Help...elevon moves when throttle is raised.
« Reply #2 on: February 21, 2016, 06:56:28 pm »
The servo plugged in to port 1 doesn't move when the throttle is raised.

f5soh

  • *****
  • 4529
    • LibrePilot
Re: Help...elevon moves when throttle is raised.
« Reply #3 on: February 21, 2016, 07:04:58 pm »
Well that strange, both elevons should move in opposite directions.

Try to swap the two elevons just for test.
If the same physical servo do the weird behavior, you can replace this servo.

kknapp

  • *
  • 6
Re: Help...elevon moves when throttle is raised.
« Reply #4 on: February 21, 2016, 07:10:51 pm »
Ok so I just tried that, the issues stayed with port 2 on the board, the servo did as expected and moved in the other direction.  I will try to reassign the elevon to another port and see if it follows.

f5soh

  • *****
  • 4529
    • LibrePilot
Re: Help...elevon moves when throttle is raised.
« Reply #5 on: February 21, 2016, 07:19:49 pm »
yes, you can use another output.

Just keep the output4 for motor and use the same refresh settings on both servos. Looks at colors for bank / output mapping

kknapp

  • *
  • 6
Re: Help...elevon moves when throttle is raised.
« Reply #6 on: February 21, 2016, 07:30:46 pm »
Ok so I just tried moving the second elevon(according to cc3d) output to port 3 and it still acts the same, whenever I increase the throttle the 2nd elevon still moves to full deflection.

f5soh

  • *****
  • 4529
    • LibrePilot
Re: Help...elevon moves when throttle is raised.
« Reply #7 on: February 21, 2016, 07:52:28 pm »
Not sure i understand fine...

"defect" servo works fine connected to output1

"defect" servo do not works fine connected to output2 or output3 ?

kknapp

  • *
  • 6
Re: Help...elevon moves when throttle is raised.
« Reply #8 on: February 21, 2016, 08:40:27 pm »
If I increase the throttle to just enough to spin the motor then 2nd elevon goes full deflection.

Normal Wiring
 * output 1 - 1st elevon
 * output 2 - 2nd elevon
 * output 4 - esc/motor

I tried to change the 2nd elevon to output 3, and the same thing happened.

New Wiring
 * output 1 - 1st elevon
 * output 3 - 2nd elevon
 * output 4 - esc/motor

The 1st elevon or output 1 doesn't seem to be affected.  I have swapped the plugs of the two servos and the issue stays with whichever output is assigned to the 2nd elevon.

f5soh

  • *****
  • 4529
    • LibrePilot
Re: Help...elevon moves when throttle is raised.
« Reply #9 on: February 21, 2016, 08:52:20 pm »
So a servo issue.

kknapp

  • *
  • 6
Re: Help...elevon moves when throttle is raised.
« Reply #10 on: February 21, 2016, 09:00:12 pm »
No it seems to be with the software both servos are fine, I tested a set of new servos that I just plugged into the cc3d board and the issue is the same.  The servo plugged into whichever output is assigned to the 2nd elevon moves to full deflection whenever the throttle is engaged.

f5soh

  • *****
  • 4529
    • LibrePilot
Re: Help...elevon moves when throttle is raised.
« Reply #11 on: February 21, 2016, 09:27:30 pm »
Strange.

Please post your config file. File > export UAV settings

hwh

  • *
  • 1018
Re: Help...elevon moves when throttle is raised.
« Reply #12 on: February 21, 2016, 09:51:14 pm »
By default I think the Turnigy 9x transmitter mixes throttle with I think it's channel 6.  Mine did anyway.

Re: Help...elevon moves when throttle is raised.
« Reply #13 on: February 22, 2016, 12:07:02 am »
Are you using Attitude mode?  It is trying to stabilize it and just tries harder and harder, but can't move the wing like it wants to.

When it does it, try tilting it a little, just like the elevon is asking for to see that this is the issue.