Jeuke26

  • **
  • 96
How to crash ( and break stuff ) in 60 seconds ( maiden )
« on: February 11, 2016, 05:48:11 pm »
Hello Fellas,

Something went seriously wrong with my beloved  :'( virgin build and maiden flight and need the help of the pro's as I can't see where it went wrong.

I flew today for the first time to test my pids in open field. A few moments after I went up I wanted to perform a flip and the roll axis ( rattitude mode ) and the moment it turned about 90dregrees the motors stopped ( as should be programmed in Librelipot at 80 degrees ) BUT the motors didn't spool up again so fell out of the sky. Did it twice to be sure and second time broke arm as it fell from almost 15 meters like a brick. I had previous succes with other quads performing the same trick without issue. Not this time.
It felt like the cc3d didn't know what to do once on its side, or upside down.

All help is appreciated and will post the UAV settings in next post.

Jeuke26

  • **
  • 96
Re: How to crash ( and break stuff ) in 60 seconds ( maiden )
« Reply #1 on: February 11, 2016, 06:15:42 pm »
here we go


f5soh

  • *****
  • 4548
    • LibrePilot
Re: How to crash ( and break stuff ) in 60 seconds ( maiden )
« Reply #2 on: February 11, 2016, 07:53:27 pm »
Looks like there is something wrong with your config file, some values are not valid and stored as "nan"

Code: [Select]
<object id="0xA86BDC0A" name="StabilizationSettingsBank3">
            <field values="nan,nan,nan,nan" name="RollRatePID"/>
            <field values="nan,nan,nan,nan" name="PitchRatePID"/>
            <field values="nan,nan,nan,nan" name="YawRatePID"/>
            <field values="nan,nan,nan" name="RollPI"/>
            <field values="nan,nan,nan" name="PitchPI"/>
            <field values="nan,nan,nan" name="YawPI"/>

This means a corrupted memory i think, did you import old (OP) settings ?
Maybe try again with a fresh reboot.

Take a look at memory free under PFD > System panel.


Jeuke26

  • **
  • 96
Re: How to crash ( and break stuff ) in 60 seconds ( maiden )
« Reply #3 on: February 11, 2016, 08:37:59 pm »
What do you mean with a fresh reboot? Thanks for finding the error ( most likely ). Could you elaborate a bit more on your post and what it means?

Philip
« Last Edit: February 11, 2016, 08:50:17 pm by Jeuke26 »

f5soh

  • *****
  • 4548
    • LibrePilot
Re: How to crash ( and break stuff ) in 60 seconds ( maiden )
« Reply #4 on: February 11, 2016, 09:21:03 pm »
Garbage because lack of memory usually.

If this values still on board, it cannot work safe.

Avoid strange settings like 90° for attitude response or/and 90° MaxAngle for cruise control.
This two settings can result in strange behavior :)

The Throttle range set to 90% max and GyroTau not LP default mean you imported old OP file at some point.

Upgrade&Erase settings and setup from scratch.


Jeuke26

  • **
  • 96
Re: How to crash ( and break stuff ) in 60 seconds ( maiden )
« Reply #5 on: February 11, 2016, 09:52:09 pm »
Ok thanks, all but the last sentence was Chinese. Will do a full clean setup. In the firmware tab I get a yellow warning triangle. Next to the firmware of the board as you probably can see. What does it mean?

f5soh

  • *****
  • 4548
    • LibrePilot
Re: How to crash ( and break stuff ) in 60 seconds ( maiden )
« Reply #6 on: February 11, 2016, 10:05:23 pm »
Maybe you miss the red window close to the download link ?



https://librepilot.atlassian.net/wiki/display/LPDOC/Downloads

Nothing bad.

Jeuke26

  • **
  • 96
Re: How to crash ( and break stuff ) in 60 seconds ( maiden )
« Reply #7 on: February 12, 2016, 09:20:08 am »
How can I check myself if there is something wrong with the memory?

Jeuke26

  • **
  • 96
Re: How to crash ( and break stuff ) in 60 seconds ( maiden )
« Reply #8 on: February 12, 2016, 11:56:54 am »
Maybe you miss the red window close to the download link ?



https://librepilot.atlassian.net/wiki/display/LPDOC/Downloads

Nothing bad.

could you help out again please. i did a complete reinstall. and watched how the firmware tab showed all green and went outside. yest again i was in flight mode 2, rattitude, to perform a flip and once again, it fell out of the sky, motors didnt spool up again. broke my second arm. once plugged in I saw that the CPU was orange saying reached max of 80% .... what goes wrong here everytime? rate mode flying went ok, attitude as well and rattitude as well, till i wanted to flip the quad and saw it behave like a brick. motors stopped and didnt spool up again, no leveling whatsoever. i saw i the advanced tab that pirouette compensation was unchecked, anything to do with it?

here are again my UAV setings.

Edit: could it have to do with the faxt that in the initial vehikel setup i choose one of the preset in the list ( black-out mini H )?

Edit 2: did again a full clean setup this time without any presets. All configured went out and....again fell out of the sky breaking my third arm in two days. Something is really wrong here. In rattitude once tilted to perform a roll everything stops working and turning and no regain of control with throttle or right sticks.
« Last Edit: February 12, 2016, 02:18:39 pm by Jeuke26 »

f5soh

  • *****
  • 4548
    • LibrePilot
Re: How to crash ( and break stuff ) in 60 seconds ( maiden )
« Reply #9 on: February 12, 2016, 05:55:04 pm »
There is numbers that looks strange, but no "NaN" this time....

The cruiseControl should stop motors after some angle: default is 105°, here set to 80°

Did you set the motor neutrals ? > motor starts at 1030 ?
Be sure the motor don't stop completely to still have some control over rotation.
The min motor is 5, maybe it really stop because wrong neutral ?

Try with quad in hand, without props and try to reproduce without fly and take attention to board reboot (monitor flighttime) or something weird
Can you give details for template you used ?

CPU alarm is caused by all options enabled: TPS, board rotation and Gimbal... maybe too much for CC3D

Jeuke26

  • **
  • 96
Re: How to crash ( and break stuff ) in 60 seconds ( maiden )
« Reply #10 on: February 12, 2016, 06:02:41 pm »
Thanks a lot. Will try all of that and report back to you.

I didn't use a preset template this time and set everything myself including PiD that worked great ( as long as you didn't roll or flip ) the max angle at default 105 is it recommended over the 80degree I set. Is there some interference. Furthermore the props did spin nicely in idle at 1030, all four. Should put it higher?

f5soh

  • *****
  • 4548
    • LibrePilot
Re: How to crash ( and break stuff ) in 60 seconds ( maiden )
« Reply #11 on: February 12, 2016, 06:16:33 pm »
The throttle still set to 90% max so you loaded some template, old config or not erased fine.


Jeuke26

  • **
  • 96
Re: How to crash ( and break stuff ) in 60 seconds ( maiden )
« Reply #12 on: February 12, 2016, 07:50:18 pm »
The throttle still set to 90% max so you loaded some template, old config or not erased fine.

Well, it's obvious you know more than I do. I did upgrade and erase than, erase all settings in vehicle setup and choose a blank template. So to you, what should I do ( settings ) to get rid of this faulty behaviour?

Could you alter the settings and send me the UAV file?

Already much appreciated your help.

f5soh

  • *****
  • 4548
    • LibrePilot
Re: How to crash ( and break stuff ) in 60 seconds ( maiden )
« Reply #13 on: February 12, 2016, 09:24:43 pm »
I don't know what you are doing exactly but after a erase the Throttle should be set at 100%, not 90%. this value comes from old (OP) defaults.
Just did locally the wizard and Throttle still to 100%.

This can be a wrong erase.

- Connect board
- Upgrade&Erase button
- Wait until board remains connected automatically.

- Check settings, all should be erased: No output and no inputs defined so SystemHealth reports INPUT and OUTPUT red alarm.

- Enable Gimbal module and Save (needed to import settings from file attached)
- Power cycle board: Disconnect/Reconnect

- Import settings from file attached:
        - File > Import UAV Settings... and load file
        - Hit "Save to board" button and wait process end (100%)

- Power cycle board: Disconnect/Reconnect

About Settings attached: only bank1 used and no TPS, the max rate is set to 500deg/s.
Flightmodes still the same for you.


Jeuke26

  • **
  • 96
Re: How to crash ( and break stuff ) in 60 seconds ( maiden )
« Reply #14 on: February 12, 2016, 11:04:48 pm »
Well again thanks for all the help. What I don't get is the max throttle 90% setting which I even don't find looking around in Librepilolt. It did TX calibration like 5 times. And didn't import old or other files whatsoever. It was a brand new CC3d from readymade Rc.

Is it not safe to put max angle at 80 degrees? Default is 105. Is 90% still ok?  Also when choosing cruise control with rate mode I get a CPU orange light... When changing to manual for throttle is goes green again. Does it mean you cannot combine it? Does it also mean the props won't stop at 105degrees in rate mode?