Re: AlwaysStabilizeWhenArmed cautions
« Reply #45 on: June 25, 2016, 06:28:23 am »
So adding TPA on the I term as well as PD was the ticket it seems.  Much much more stable inverted
5" alien 4s 596grams with battery and GoPro FPV
Lantian LT210 4s 604grams with batt and GoPro FPV
GE X220 4s 6" 513grams with batt and HD cam FPV
Homemade acro X copter. 6" 4s - like a warpquad LOS

Re: AlwaysStabilizeWhenArmed cautions
« Reply #46 on: June 27, 2016, 12:04:05 pm »
Hello Forum,

I have just had a read through this thread as I am interested in implementing ASWA.

I followed the instructions that I found here and believe I am close with to dialing in my settings. However I have an issue.

I am running a 6 channel system (FlySky) so I am able to have two auxiliary inputs.
Until now, I used the two extra inputs for "arm" and "flight mode"
For both I was using toggle switches with two positions.
For my flight modes I had, "angle" and "stabilize" modes set.
For arm, I believed I had "arm" and "disarm" set.

I tried today to follow the instructions here to set ASWA and *MSANOWAATBZ to true and checked.

It all seemed great, and when I armed my MR the motors began to idle as expected.

However, when I flipped the "arm" switch back, with throttle at 0, the motors did not stop idling.

I unplugged the battery at this point as I did not want to do anything unsafe. Though I'm excited to fly with this new mode.

I am wondering if someone can help me with my problem. Is there a setting I am missing regarding the "arm" switch that will allow me to disarm my MR.

Ideally, I would like to have my flight modes control the on/off of the ASWA function as well as idling, however, it seems this will be coming with the next update.

For now I would simply like to be able to arm the MR then just disarm when I am very close to my landing pad.

MY DISARM SWITCH DOES NOT STOP MOTORS FROM IDILING?

Thanks in advance for any help with this, and thank you to the developers of this wonderful platform.


* MSANOWAATBZ -  ''motors spin at neutral output when armed and throttle below zero''
       -haha sorry, this is the longest acronym I've ever typed, maybe a bit excessive.

f5soh

  • *****
  • 3875
    • LibrePilot
Re: AlwaysStabilizeWhenArmed cautions
« Reply #47 on: June 27, 2016, 12:07:02 pm »
Be sure the neutral value is set to middle range on Accessory used as arming switch.

Re: AlwaysStabilizeWhenArmed cautions
« Reply #48 on: June 30, 2016, 07:04:16 am »
...
when I invert(hang time) and float, I get a wandering yaw. Not uncontrollable. I have complete control, but it's like a "too low of I gain" type of yaw drift.
...

Most people have soft yaw PIDs.  I would increase yaw PIDs.  I would also consider using AxisLock instead of Rate on yaw.  You can tweak up AxisLock to hold harder if desired.

Re: AlwaysStabilizeWhenArmed cautions
« Reply #49 on: July 08, 2016, 10:00:08 pm »
Thanks F5soh, that was the issue. Now my arm switch works great. I like the new mode, makes things more reliable and fun.

Still need to play with PIDs though as the flips either happen very slowly, or on higher PID modes I have set, flips/rolls happen faster (still not as fast as I've seen in youtube videos of others) but there is lots of wobble after I stop putting in commands. Going to need a field day with the laptop to really dial it in.

Thanks F5soh for the help :)

Fokke

  • *
  • 1
  • Beginner
Re: AlwaysStabilizeWhenArmed cautions
« Reply #50 on: July 13, 2016, 09:12:47 am »
Very helpful thread, thank you all for sharing. As of today, there still is no next release for LibrePilot available (without compiling it yourself, which I haven't tried), so this is still very actual for LibrePilot users. The screenshots on the LibrePilot Jira ASWA Settings (https://librepilot.atlassian.net/wiki/display/LPDOC/Always+Stabilized+When+Armed+mode+setup) seem to come from the still to be released update, so if you're in the same boat as I am using the LP 15.09 version, stop looking for that option to set an accessory switch for ASWA, wait for the next version and set it up like described in this thread.

I checked MotorSpinningWhenIdle under the Output tab in LP 15.09 and set ASWA to True (Settings>FlightController>ASWA>TRUE).

I am confident this will solve my problem: before now I have had issues with losing control temporary when killing the throttle when doing maneuvers in rate mode. So I was looking for the airmode (cleanflight) alternative for LibrePilot. I have yet to test in flight, but I notice the motors are responding to Pitch and Roll inputs when the quad is on the ground with motors spinning when armed.

P.S. Everybody knows this, but to be sure: Only do this when you use a physical switch to arm your quad (I use a 2-pos switch > Accessory0), for using yaw-right may cause you to disarm your quad in mid flight when flying Rate/Acro+ mode. I can also imagine it would be safe to check your Gyro calibration before flying, to make sure the craft thinks it is leveled before you arm when in Attitude mode. (Otherwise it may try to correct as soon as you arm, possibly resulting in a flip.)
Hoverthings FLIP 260 - DYS BE-1806-13 - DYS 16A BLheli - HQ 5x4x3 props - CC3D - 3S 1400 - HS1177 - Boscam VTX - Fatshark Teleporter V3 - Taranis Plus

Wagsy

  • *
  • 87
    • Rotorpix
Re: AlwaysStabilizeWhenArmed cautions
« Reply #51 on: July 16, 2016, 12:03:28 pm »
Great read, just set it up on my 400 with a REVO in it.
Try tomorrow see how it compares to Cleanflights.
Also have the GPSV9 on it and will tune the RTH etc.

YipYip

  • *
  • 2
Re: AlwaysStabilizeWhenArmed cautions
« Reply #52 on: July 31, 2016, 11:22:01 pm »
This is a really nice feature but I have a question.

Just started out in the quad world with my ZMR to learn how to fly with something cheap. I think I´ve gotten it to fly pretty good so I thought I´d try out this ASWA thing.

Problem is, if I switch flightmodes with the quad armed, it seems like it takes a second or so to "boot up" the new flightmode, cutting the motors in the meantime. I plug everything in, arm the quad, it starts up idling and everything is working, the motors respond to stick movements even with throttle at zero. Then I try to switch flightmodes from attitude to rate for example but when I do, the motors stop spinning for a second.

Haven´t tried it in the air yet fortunately, but I really would like this problem to go away since I´m not really good enough yet to always fly rate. I need my leveling for takeoff and landing at least :P

Re: AlwaysStabilizeWhenArmed cautions
« Reply #53 on: August 02, 2016, 04:30:08 am »
Yeah that should not do that.  It should be seamless switching between all flight modes.  The motors should never stop.
« Last Edit: August 02, 2016, 04:33:33 am by NicholasDavid »
5" alien 4s 596grams with battery and GoPro FPV
Lantian LT210 4s 604grams with batt and GoPro FPV
GE X220 4s 6" 513grams with batt and HD cam FPV
Homemade acro X copter. 6" 4s - like a warpquad LOS

YipYip

  • *
  • 2
Re: AlwaysStabilizeWhenArmed cautions
« Reply #54 on: August 03, 2016, 01:02:35 am »
Yes I figured that too.

Seems to be intermittent as well because it doesn´t always happen which makes it even harder to troubleshoot.

Also, it messed up my failsafe (don´t have a failsafe on the TX) so now when signal loss happens the motors go to idle and I want the FC to cut throttle. I clearly need more tinkering with this one before I actually take it out flying with ASWA enabled.

f5soh

  • *****
  • 3875
    • LibrePilot
Re: AlwaysStabilizeWhenArmed cautions
« Reply #55 on: August 04, 2016, 09:59:25 am »
Hi,
Please post your config file:
File > Export UAV Settings

alecal

  • *
  • 1
Re: AlwaysStabilizeWhenArmed cautions
« Reply #56 on: September 27, 2016, 07:05:59 pm »
When selecting "Motor Spin at neutral..." I cannot see the option to select the accessory that I can assign to trigger this action. 

f5soh

  • *****
  • 3875
    • LibrePilot
Re: AlwaysStabilizeWhenArmed cautions
« Reply #57 on: September 27, 2016, 07:43:08 pm »

Re: AlwaysStabilizeWhenArmed cautions
« Reply #58 on: November 19, 2016, 09:41:47 am »
Hi,

Got the same problem when switching flightmodes, sometimes all motors stop for a second. It happens just after activating "zero integral when throttle is low". But dont know if thats the problem. Also not tried to activate aswa...
Hardware: F450 Frame--Revolution Board--EMax 2213-935kv--BullTec 30A Opto--5000mAh 3S 30C LiPo--NEO M8N GPS+MAG--Fr Sky Taranis Plus + OPLink Mini
Addon: sj5000x + two axis gimbal + minimosd + eachine VT + easycap
Software: Black Rhino, LP2GO

Re: AlwaysStabilizeWhenArmed cautions
« Reply #59 on: November 19, 2016, 02:22:35 pm »
So now tried every combination aswa on/off, zero integral on/off but still happens when i switch flight mode (altitude hold to manual thrust or attitude mode to position hold and back) copter is falling from the sky and needs about 2 seconds for restabilize itself. But then it holds position well. Any ideas?
Hardware: F450 Frame--Revolution Board--EMax 2213-935kv--BullTec 30A Opto--5000mAh 3S 30C LiPo--NEO M8N GPS+MAG--Fr Sky Taranis Plus + OPLink Mini
Addon: sj5000x + two axis gimbal + minimosd + eachine VT + easycap
Software: Black Rhino, LP2GO