vgwit

  • **
  • 94
Can not get maximum thrust
« on: July 18, 2019, 09:45:42 pm »
Hi experts,

I use Revo mini connected to receiver via I-Bus and ESCs in OneShot125 mode. Have moved to Next software version and passed from scratch through config wizzards.

While testing different props I've discovered that have got thrust and consumed current values lower than expected. GCS output tab motors values are set to 1000 for min and 2000 for max.  Live testing with sliders gives pulse width on FC output from 125 to 250us as expected. But using transmitter I see only about 237us for maximum throttle and System -> ActuatorCommand shows about 1900 (1900/8=237) and ActuatorDesired 0.9 as maximums. Throttle range in input tab is set to 1000 - 1984. Have tried to change max for throttle a bit but did not see a difference.

How to get full 250us pulse using transmitter?
Thanks.
« Last Edit: July 18, 2019, 10:06:57 pm by vgwit »

f5soh

  • *****
  • 4572
    • LibrePilot
Re: Can not get maximum thrust
« Reply #1 on: July 19, 2019, 12:05:30 am »
Hi,

Please post your config file before investigate...

How about the Throttle curve in Input tab ?

vgwit

  • **
  • 94
Re: Can not get maximum thrust
« Reply #2 on: July 19, 2019, 08:26:15 am »
Actually I should have guess...

My last test was to give a max throttle with transmitter to the quad resting on a table without props. And the remainder 250-237us is probably a room to have a possibility to make maneuvers in real flight.

Just in case, settings attached.

f5soh

  • *****
  • 4572
    • LibrePilot
Re: Can not get maximum thrust
« Reply #3 on: July 19, 2019, 12:29:10 pm »
Your Thrust limitation (from stick) is due to all flightmodes using CruiseControl and CruiseControlMaxThrust = 90%.



Re: Can not get maximum thrust
« Reply #4 on: July 19, 2019, 08:04:16 pm »
That is odd...   :o  The default for that is 100% even back in 16.09.   :)

It was before that, in OpenPilot 15.x, that the default was 90%.