I think I bricked my controller
« on: January 27, 2019, 01:05:22 am »
I just finished a very careful build of a new QuadLug Box Copter.  Everything went perfect right down to pairing the controller.  Last step was to upgrade the software and make the adjustments.  I downloaded Libre Pilot 16.01 on my windows XP computer.  I connected the CC3D Controller to a USB cable and connected that to my computer.  It connected perfectly.  I had one green Tx light and a few green Rx lights with a yellow and a red one I believe.  I was following "Danny's" video on how to do this.  I start the set up wizard and I get to software upgrade and start that process and all appears normal but it got stuck on "booting and erasing, please wait".  Then this timed out and red text appears to manually use the "uploader plug-in" which I did.  This process seemed to go as usual and finished with a yellow triangle with an exclamation point in the middle and that is never good.  But all my "status" lights at the bottom of the page went out except one Tx green light.  If I tried to do any of these processes again I get a message to connect the board or "board not connected" and nothing happens.  I now fear I have "bricked" this CC3D controller.  The green and blue lights still come on and flash but but it won't "connect" and of course the copter doesn't do anything as I never finished the process.  Any idea's or is the board finished. 

I so appreciate your help.


Re: I think I bricked my controller
« Reply #1 on: January 27, 2019, 05:53:14 am »
First of all, your GCS (PC program) version must match your firmware version.  If Danny told you to download something then it may not match.

Unplug your board, go to the Firmware tab, press Rescue, plug the board in.  Does this work and connect and tell you what version your bootloader is?
If it worked (and your bootloader version is V4), you should be able to just press UpgradeAndErase.  During the erase portion, make sure to let it run for at least a minute or two.  FlightTime should count up to say 120 before powering it off.  If everything is working now, you are done.

Here is a link (to an off site link) on how to update your bootloader if it is V3 (it needs to be V4).
Also, you might be able to use CleanFlight to flash ef_coptercontrol.hex if you would rather try that than the external link instructions.

Please post a link to the Danny's video so we can see if he does something wrong.

Re: I think I bricked my controller
« Reply #2 on: January 27, 2019, 07:45:35 am »
THAT DID IT "TheOtherCliff"!!!
I did exactly what you told me here and it worked and I'm up and running.  Yes it was V4 so I got lucky there and the "Rescue" did it!!  I just finished flying it for the first time a few minutes ago and what a rush!  My hands are still shaking for sure.  But it was so cool.  Not only to build it but to actually FLY IT!!!! ;D

Thank you so much for taking your time to help me here as I so appreciate it.  What a learning experience and a lot of fun.  While this is my first quad it certainly won't be my last.

Best regards,