Mark36

  • *
  • 33
Hy all ! :)
I tried on the forum if someone had the same problem, but I did not find anything so I opened a new topic. I'm doing the first configurations on the Revolution, and I want to activate the communication from PC to the Drone through OPLink mini, so that I can configure the Revoltion (and the UAV) without using the usb cable from the pc.
I have read the page "OPlink configurations" on the librepilot website (and other pages), I have followed all the configurations, but the oplink does not dialogue with the revolution.
I attachments the screenshots of my configurations; HW and BL I think they are ok both on OPLink mini and on Revolution .. but I do not understand where the problem is ... maybe it's on the configuration of the Revolution ports .... because I have doubts about the configuration of the ports for the OPLink mini .....
In particular on librepilot I have not found what I have to select at the "Radio Aux Stream" port
Also I do not know what I have to select for the "USB HID Function" and "USB VCP Function" port.
To give you more information on how I set up my ports:
-1-on the "Receiver port" I connected minimosd and status led
-2-on ​​the "Flexi Port" I connected a GPS NAZA
-3- and finally on the "main port" I connected the S.Bus to the receiver (R9M).
Many Tnks

Getting them to connect (for telemetry) should be a fairly straight forward process (from memory):
- put antennas on both ground and air
- set both ground and air to the lowest power level: 1.25mw
- set the ground to OpLinkCoordinator
- set the air to OpLinkReceiver
- copy the device ID from the ground and put it in the CoordinatorID field in the air
- power air normally via flight battery -> ESC/BEC -> FC
- plug ground into USB / GCS
- watch that OpLink connects in lower right corner of GCS
- watch tx/rx scale at the bottom in the middle
- everything else default
- data rate must match on both sides; sometimes it helps to increase to the next higher data rate on both sides
https://librepilot.atlassian.net/wiki/spaces/LPDOC/pages/2818098/OPLink+Configuration

At lowest power, you should get 10's of meters even with bad antennas; hundreds of meters with good antennas.
https://forum.librepilot.org/index.php?topic=4199

Be aware that there are some bad RF boards being sold these days.  Good works well with good, and bad supposedly works well with bad, but good does not work (well) with bad.  It seems the channel hop order is different on the bad ones.
https://forum.librepilot.org/index.php?topic=4197

Mark36

  • *
  • 33
Thank you very much TheOtherCliff for your precious and fast support!
I changed the power settings to 1.25mw, but the OPLink does not communicate with the Revolution.
I also checked the RF boards, but for me it does not seem to be the faulty model (see attached photo).
I followed your directions but everything seems to be okay, but there is no communication.
I repeat that I have absolutely no idea how to set the ports in "HW settings" to run the OPLink.
Can someone explain how to set the ports (these I highlighted in red in the attached file) to make the OPLink work ?? I do not see anything written on the internet page about configuring these ports to make OPLink work ...
Thank you

f5soh

  • *****
  • 4494
    • LibrePilot
There is no need to change something in HW page, except if you want to use auxiliary stream.
All the Oplink configuration (Ground Oplink and Revo) is done in OPlink tab.

Mark36

  • *
  • 33
Tnks F5soh,
ok then I disabled those ports (see attached image).
My OPLink still does not work, I posted all my settings here in this post, they seem to be correct, I do not understand where the problem is ...
Perhaps the problem is related to the fact that I made only "vehicle setup wizard" ??

f5soh

  • *****
  • 4494
    • LibrePilot
Try setting the Air data rate to maximum (256000) in both sides.

Mark36

  • *
  • 33
I found an imperfect solder on the RF module of the Revolution (see red circle attached photos), I tried to restore the solder (green circle), I tried the OPLink again and it still does not work ..
Then I followed the advice of F5soh, and I tried setting the Air data rate to maximum (256000) in both sides .......................... ...................... finally the OPLink communicates with the revolution! Hallelujah!

But why did I have these problems? do I still have a bad FC board ??

Tnk so much to everyone!!  :)

f5soh

  • *****
  • 4494
    • LibrePilot
Previous bad solder will make a short between antenna pad and ground...
If you want to improve the range a little you try to reduce the Air data rate to 100000.

256000 data rate allow connecting when Rf modules are not well tuned : look AFC correction value (should be around 0) and adjust the Xtal capacitor if needed.

Then I followed the advice of F5soh, and I tried setting the Air data rate to maximum (256000) in both sides finally the OPLink communicates with the revolution!
- data rate must match on both sides; sometimes it helps to increase to the next higher data rate on both sides



But why did I have these problems?
Two reasons: the solder blob, and the source code for the default data rate should probably be changed to a higher number.  Or instead of increasing source code data rate default value, we could change the source code to disable some unneeded messages to decrease the amount of data that is sent, so higher data rate is not needed.  The user can also disable these unneeded messages, but it is easier to just tell the user to increase the data rate.



Do I still have a bad FC board ??
At lowest power, you should get 10's of meters even with bad antennas; hundreds of meters with good antennas.
https://forum.librepilot.org/index.php?topic=4199
If you use good antennas as tested in the linked thread, and you get solid, constant connection (not dropping and reconnecting every few seconds) to hundreds of meters at lowest power, then everything is working well.
« Last Edit: December 09, 2018, 10:09:56 pm by TheOtherCliff »