jdl

  • ***
  • 107
Little help needed...
« on: November 26, 2018, 01:15:01 pm »
Hi,

I reported an issue regarding PathPlanner module.

https://librepilot.atlassian.net/browse/LP-605. The fix I propose is in the description.

I created a new branch LP-605-PPResume-Fix, made changes to pathplanner.c and pushed the commit to that branch.

Now I hesitate should I create a pull request to the "next" branch or not? This is my first expirience with the git workflow and I do not want to do something wrong, harmful or generally useless. Little help from expirienced developers would be appreciated! :)

There is one more confusing moment. I see the issue as reported by me, but I cannot find a way to assign it to me? What am I doing wrong?

Re: Little help needed...
« Reply #1 on: November 27, 2018, 04:43:19 am »
Once you sign in to Atlassian, you should see an "Assign to me" link right under the "Unassigned".  If not, then it sounds like you don't have enough permission yet.  In any case, Laurent (@f5soh) would be the man to help you.

Being the first issue you have done, I would discuss it in dev chat to see if it meets standards.  You may need access (Laurent) to that too.

It generally isn't possible for a new dev to do anything too bad since you are just modifying your own branch and generating a pull request that gets voted on and if it passes, gets merged by someone else.

Have you got any blockers running in your browser?  I have NoScript and I typically just temporarily allow some required sites when I need to do something in the dev stuff.


jdl

  • ***
  • 107
Re: Little help needed...
« Reply #2 on: November 27, 2018, 01:59:16 pm »
Thanks, Cliff! I admire your patience and concern to support / help / share knowledge with anyone on Librepilot forum, no matter how sane or not so are the questions asked. I do appreciate this!

Btw, today I see the link!?
I was logged in Atlassian yesterday... And the link wasn't visible then. I hadn't changed anything meanwhile, and I do not run any blockers in my browsers.

Anyway, now I see the "Assign to me" links in unassigned Jira issues. And, apparently, I've got a support from f5soh, thanks! Now the LP-605 is tagged as assigned to me.

I'll follow your advice to ask in the devs chat for confirmation before generating the pull request.

f5soh

  • *****
  • 4476
    • LibrePilot
Re: Little help needed...
« Reply #3 on: November 27, 2018, 07:02:30 pm »
Simply added you to Jira-devs group.

jdl

  • ***
  • 107
Re: Little help needed...
« Reply #4 on: November 27, 2018, 07:47:39 pm »
Got it.
Thanks!

karla

  • ****
  • 475
Re: Little help needed...
« Reply #5 on: November 29, 2018, 01:56:16 am »
Quote
Thanks, Cliff! I admire your patience and concern to support / help / share knowledge with anyone on Librepilot forum, no matter how sane or not so are the questions asked. I do appreciate this!

+1