Wid

  • *
  • 15
Oscillation during hover attitude mode: SOLVED
« on: October 12, 2018, 03:11:19 am »
I am getting oscillation while hovering in attitude mode. Maybe 2 or3  per second. Things settle down when I move the pitch or roll sticks. What do I need to adjust or check?
« Last Edit: October 14, 2018, 02:30:25 am by Wid »

Re: Oscillation during hover attitude mode
« Reply #1 on: October 12, 2018, 09:10:08 am »
What FC is this?

If Revo class, what is your Attitude->Settings->AttiEstAlgo?
If Revo class, are you using GPS Assist?
If these are true then you probably need to reduce the brake PID or similar (VtolPathFollowerSettings)?

Wid

  • *
  • 15
Re: Oscillation during hover attitude mode
« Reply #2 on: October 13, 2018, 05:51:19 pm »
I am having the same problem on 2 250 quads. One FC is an old Atom CC3D and the other is a old "regular" CC3D. I am not using GPS or GPS assist. I am using sbus. Part of my problem is I am inexperienced with quads and FCs so flights, experimentation and analyzing results are slow going. My comprehension of all the settings involved with LibrePilot GCS is taking awhile to get up to speed. I am learning and studying and watching lots of videos. VTx and camera arrived so will install them to help see better what is going on. Thanks for your patience and help.
« Last Edit: October 14, 2018, 08:42:15 pm by Wid »

Re: Oscillation during hover attitude mode
« Reply #3 on: October 13, 2018, 05:55:47 pm »
If you are running default PIDs the next most likely thing is that you are running a slow ESC protocol like [email protected]

It should be at least [email protected] or PWMSync

Top of Output page

Wid

  • *
  • 15
Re: Oscillation during hover attitude mode
« Reply #4 on: October 13, 2018, 06:30:49 pm »
YEP. Running [email protected] If I change it on the output page do I need to re-calibrate ESCs.
I have 12 amp:
https://www.banggood.com/Emax-Simonk-Series-12A-20A-25A-30A-40A-ESC-For-Quadcopter-QAV-250-p-918126.html?ID=511756
I have not flashed them.
Should I use [email protected] or PWMSync?

Re: Oscillation during hover attitude mode
« Reply #5 on: October 13, 2018, 07:20:25 pm »
Running [email protected] If I change it on the output page do I need to re-calibrate ESCs.
It depends.

Should I use [email protected] or PWMSync?
For most modern ESCs, if you calibrate your ESCs with min=1000 max=1900 (instead of min=1000 max=2000) it works well with either [email protected] or PWMSync.

As I recall:
To use PWMSync, your ESCs must be calibrated with something like min=1000 max=1900
With [email protected] you can probably get away with min=1000 max=2000, but max=1900 works fine too

That is because PWMSync is basically [email protected] which cannot run with max=2000.  The pulse happens 500 times a second.  Max=2000 means pulse width is 2000us = 2ms = 2/1000 second = 1/500 second, so at full throttle there is no pulse "off time" to measure the pulse width against.

Easy ESC calibration:
https://librepilot.atlassian.net/wiki/spaces/LPDOC/pages/12058743/ESC+Calibration
« Last Edit: October 13, 2018, 07:48:20 pm by TheOtherCliff »

Wid

  • *
  • 15
Re: Oscillation during hover attitude mode
« Reply #6 on: October 14, 2018, 02:29:55 am »
That fixed it. Rock steady now! And thanks for the link to ESC calibration. I had been a bit confused about which beeps when.
Thank you very much.
Wid