On-Screen Control Movement Not Showing at Step for Inversion Check
« on: September 14, 2018, 12:34:50 am »
I have a 230 class FPV drone I'm building and the CC3D board using an S-Bus FrSky RX and Tarranis QX7 TX. I have gone through the vehicle setup, seen the motors turn, and saved the config. I then went to the TX setup after I bound the TX and RX. I started the TX wizard and it registers or knows my Acro, Mode 2 (throttle-left, pitch and roll right), and then I did the movements and it knew I was moving things. I also checked another tab and saw channels 1,2,3,4 were set and channel 5 mode was disabled because I skipped the toggle switch on the picture because it stays in one position and the left switch wasn't showing. I get to the picture of the 4 channels as checkboxes across the top but when I move the controls nothing moves on my software program screen (using Mac version). I saved anyhow and tried to control the drone with the TX and nothing works. Does anyone know how I can get beyond the screen where I check to see if anything is backward or see the stick movement? I upgraded firmware to match the latest version of ground control software too. I also tried using the custom selection for the vehicle and then I've tried the second choice or racing FPV model.

Lost here in Raleigh NC,

David Whitehurst

Re: On-Screen Control Movement Not Showing at Step for Inversion Check
« Reply #1 on: September 14, 2018, 05:24:24 pm »
There is a minor bug in that the animations in the later part of transmitter wizard don't work unless you have a 5th channel set up as a Flight Mode Switch.

One work around is to carefully follow instructions, pretending that the screen does show the sticks moving.  Especially be careful where it tells you to move each stick to full position in both directions.

See if that helps.  Other people can help more if this doesn't work for you.