Throttle range anomoly
« on: August 24, 2018, 03:27:20 am »
I'm trying to set up a new quad: HK/Dead Cat 450 frame, Spektrum DX-9, Orange Rx, Afro ESC's with Simon K firmware, Multistar Elite 2216 motors.
The Wizards work as they should, including calibrating the motor starting signal at 1063 mS  for all 4. Failsafe and arming settings also worked as they should. 
Test flight didn't go as well, as the first half of throttle stick movement did nothing and the last half RAPIDLY accelerated the motors, which made for "difficult" control.
I've checked the "monitor" screen on my DX-9, which shows a progressive throttle range from -1 to +1, verified the throttle range on the Input screen of Librepilot (which shows a range from 1050 mS to 1964 with half throttle being 1518).  When I plug a servo into the throttle port of the receiver, it moves smoothly and progressively with the throttle stick through its full range.
I'm flummoxed about why I've lost half my throttle stick movement.  Any ideas?

Re: Throttle range anomoly
« Reply #1 on: August 24, 2018, 03:36:15 am »
Input->Throttle->Neutral needs to be very close to Min, not half way from Min to Max.

Try making it say 4% or 40 units above Min.

Re: Throttle range anomoly
« Reply #2 on: August 25, 2018, 03:14:19 am »
As usual, the advice I've receive has been excellent - it worked.  I'd tried resetting the throttle range in the "Servo Travel" and "Throttle Curve" menus on the transmitter, which didn't work very well.