Big mistake in CC3D
« on: June 10, 2018, 11:33:27 am »
Hello everyone. I need your help. I have a CC3D. I flashed it with CleanFlight, then stupidly I flashed it again with CC3D_OPBL using CF flasher. Then all the problems started. I only get a solid green light and can't communicate with the board or flash it using either the main port or even the USB port. I have tried flashing using CF, BF, GCS(all of them) and I also tried flashing the bootloader using STM Demonstrator. And NO I am not forgetting to short the SBL and 3.3V pins. I have attached some photos of my board. Whenever I try to flash it, it says, no response from the bootloader(or something similar). I have tried Naze32 (with BF, CF, and dronin) it is nowhere as good as CC3D with dronin. I can't afford a new one (if I could I wouldn't bother to write). I think I found something -
please can you help me find a solution? Thanks In Advance.

Re: Big mistake in CC3D
« Reply #1 on: June 10, 2018, 04:20:57 pm »
It sounds like the BL has been corrupted.  CC3D uses an F103 CPU which does not have USB SBL support, so to flash a BL using SBL you must go through a serial port (MainPort) using an FTDI (USB to serial converter).

This wiki search:
Leads to this wiki page:
Leads to this external article for CC3D: