trike_flyer

  • *
  • 15
  • If it was easy we wouldn't do it!!
cc3d going into failsafe boot
« on: May 17, 2018, 09:12:38 pm »
Hello

My cc3d mini has started acting bad.  When I power it up it has trouble doing a boot up.  After plugging into librepilot it tells me it booted into a failsafe mode. in doing so it looses all my settings and is unflyable.  Is there a problem with some of the boards loosing info and becoming bad?  I have tried a rescue and upgrade to no luck.  Do i need to leave it plugged in for a while to recharge something on the board?

Thanks for any help in this.

TF

Re: cc3d going into failsafe boot
« Reply #1 on: May 17, 2018, 09:56:21 pm »
Save settings if you can, not the default ones, but the real ones.

Maybe try with battery in addition to USB.  Maybe try with ports disconnected.  Maybe look for crushed pins inside mainport and flexiport.

It's possible that you enabled some options that caused this, for instance, CC3D is low on memory.  Enabling many features could cause this.

Finally do Rescue (or just boot to default settings after normal boot failure) then Erase Settings and start over.  Save settings as you go, before enabling a lot of stuff (e.g. telemetry and GPS for OSD).

trike_flyer

  • *
  • 15
  • If it was easy we wouldn't do it!!
Re: cc3d going into failsafe boot
« Reply #2 on: May 18, 2018, 04:41:59 am »
Thanks Cliff for the reply.  I tried using a battery to boot then plugging in the usb.  Seems like the com is stuttering when I plug it in.  Like windows does three resets on it before it is happy.  Is there an onboard battery that has to charge and looses its charge when it is down to long?  I tried a rescue and update firmware and thought it was good but it did it again. I think one of the chips went flakey on it.

TF

Re: cc3d going into failsafe boot
« Reply #3 on: May 18, 2018, 05:08:49 am »
No battery or such.  Either it's broken or you have enabled too many high memory things.

If you suspect you know what setting you changed that broke it, you can just (all without rebooting) change that setting, then change it back to default, then reboot because it will save changes even when booted from default state.

Else: Not rescue and update, you must "erase settings" and start over.  Erasing settings should get it where it boots correctly (with minimum changes, just to know that it is actually using your config and not default).  Verify that it saves some minimum small change (like a PID change of 1 unit) through reboots.

trike_flyer

  • *
  • 15
  • If it was easy we wouldn't do it!!
Re: cc3d going into failsafe boot
« Reply #4 on: May 18, 2018, 06:13:25 am »
The only change I did was change telemetry to MSP for the osd to talk to it. I will try another rescue and see if that fixes it or a total boot loader reflash and start again.  Will let you know how it goes.

TF

Re: cc3d going into failsafe boot
« Reply #5 on: May 18, 2018, 12:39:10 pm »
Telemetry MSP uses a lot of memory.  That would probably do it.  As previously discussed, you can save yourself some work by booting into default and setting telemetry (say first to MSP, then) back to none, then rebooting to see if that fixes it.