karla

  • ****
  • 451
Re: RevoNano and LED using WS281x
« Reply #30 on: April 27, 2018, 05:31:27 pm »
For the record, I am in fact using only Revo Minis right now, not the full-size Revo or the Nano.

Are you using the Atom board?
https://librepilot.atlassian.net/wiki/spaces/LPDOC/pages/2818090/CC+Hardware+Configuration

karla

  • ****
  • 451
Re: RevoNano and LED using WS281x
« Reply #31 on: April 27, 2018, 05:41:48 pm »
You really only need to move whatever is on channel one.  Just move it (only it) to the end instead of shifting them all down one place.  :)

Thats true. However, it can get really confusing to keep track of the heli setup of the swash plate servos if you do.

Re: RevoNano and LED using WS281x
« Reply #32 on: April 28, 2018, 06:35:13 am »
   Karla, the board I'm using is shown in mr_w's post #18 on page 2 here in this thread, the one shown in the upper photo.  Here's a link to its user's manual:
https://d3vs3fai4o12t3.cloudfront.net/media/attachment/file/h/p/hp-fccc3dminif4-man.pdf

Librepilot detects and treats it as an original Revo, not as a Nano or Atom or Mini. 

karla

  • ****
  • 451
Solved: RevoNano and LED using WS281x
« Reply #33 on: April 29, 2018, 12:25:35 pm »
Thank you Bobrcnut.
Also,

How about the power voltage ?
WS2812B has absolute voltage range from +3.5V to +5.3V max.
It's 5.47V, my BEC output 5.5V but can be set to 5.0V.

I changed the BEC output to 5.0V and now the LED is working fine even with all peripherals like GPS, Current sensor, Camera switcher, OSD and telemetry is enabled.
Thank you all.
« Last Edit: April 29, 2018, 12:30:53 pm by karla »

Re: RevoNano and LED using WS281x
« Reply #34 on: April 30, 2018, 11:10:31 pm »
Karla:  Thank you for checking.  I was 'led' (no pun intended) astray by the Matek web site, which says 4-7V for the LED strip I'm using.