trust

  • *
  • 24
Mixers not working
« on: April 06, 2018, 03:48:39 am »
I've been trying to modify an Atom CC3D, and modified the output 1 and 2 mixer settings. But nothing seems to be changing.
I can disarm, modify settings, rearm, they appear in systems and on the menu, but when I move the throttle, it goes from off to half throttle instantly, and there is no gradation, no matter what values I input in the throttle curves.
I had it set to motor outputs, tried changing it to servo, back to motor - nothing works.
Also, how do you change the assignment names in output?
I also have problems with inputs - I can't seem to disable them. They're marked disabled in the inputs, but I get a red I/O warning and nothing works if all the previously used inputs aren't hooked up to something. How do I disable inputs so they don't disable everything?

Re: Mixers not working
« Reply #1 on: April 06, 2018, 06:00:39 am »
First take props off.

Go to Output page.  For motors, the neutral setting should be very close to min.  Typically min, neutral, max is something like 1000,1080,1900.  When you move the throttle stick just a small amount above the bottom, the output jumps from min to neutral by design.  If neutral is high, like 1500, then you get medium motor throttle just a little way above the stick minimum.

While there, you can enable "Test Outputs", then use the sliders to test that each motor can run from very slow to full speed.  If they do nothing till you get the slider to the middle, then the ESCs need calibrating.

Here are instructions to calibrate ESCs and set motor neutrals.
https://librepilot.atlassian.net/wiki/spaces/LPDOC/pages/12058743/ESC+Calibration

trust

  • *
  • 24
Re: Mixers not working
« Reply #2 on: April 06, 2018, 07:08:58 am »
I checked the outputs - they are fine when operated manually with the sliders. The ESC's dont need calibrating - I get a nice ramp up on power.
When I use the receiver throttle it jumps from off to neutral, then doesn't change for the whole range of throttle movement.
Min is 1000, neutral 1200, max 1900
I have mixer curve 1 at 127, curve 2 at 127 and all others at 0 except yaw at 127. I've tried changing these values and nothing changes.
?

f5soh

  • *****
  • 4336
    • LibrePilot
Re: Mixers not working
« Reply #3 on: April 06, 2018, 05:39:39 pm »
Please post your config file.

Re: Mixers not working
« Reply #4 on: April 06, 2018, 05:54:26 pm »
And after posting your config file

... we have proven that the output is set reasonably.  Although 1200 is the highest motor neutral I have seen, it is usable.

Either the input is not calibrated or something about the mixer is wrong.

Look at the input page with both flight battery and USB connected.  You say that motors never go above neutral.  One explanation for that is that your input range is not configured correctly.  Is the Input motor neutral set very low like it probably needs to be?  Does the throttle slider move across the whole range, including up to max (when you move the transmitter stick over the whole range)?  Is the range too restricted so that past a certain point, the slider is max, but the stick still has more travel?

If I need to do something manually configuring the mixer, I usually start with a known mixer that works, like for a quad or for a fixed wing and then click to convert that to custom.  I haven't seen the explanation of what you are trying to do with the mixer and how you have it set.  It's easiest to just post your config file.  If you understand what they are doing, mixers make sense, but most people don't bother.

trust

  • *
  • 24
Re: Mixers not working
« Reply #5 on: April 06, 2018, 06:59:39 pm »
Input values for throttle seem fine to me. Here's the uav file.
Thanks. These machines have allowed us to make great strides in developing new concepts. We're trying to move up another notch, using more features to remove need for external switches and mode changes.

f5soh

  • *****
  • 4336
    • LibrePilot
Re: Mixers not working
« Reply #6 on: April 06, 2018, 07:19:49 pm »
You set both curves at 127 for both motors, this means the output is saturated at half Throttle.
So you should use only one curve (like curve1) and set the curve2 to 0 instead of 127 in Custom mixer.



Except this expected output saturation, all is working fine.
Motors are only active if board is armed.

trust

  • *
  • 24
Re: Mixers not working
« Reply #7 on: April 06, 2018, 09:01:29 pm »
I set the throttle curve 2 values to 0, and armed it. Same result. FYI - I have servo in place of the 2nd motor, so I can visually see the levels. On increasing throttle, the motor turns on (servo jumps up about 20%), then that's it - all the way to full throttle on the input, the outputs stay the same.
?

f5soh

  • *****
  • 4336
    • LibrePilot
Re: Mixers not working
« Reply #8 on: April 06, 2018, 09:15:15 pm »
As you see in Scope attached the outputs works, and not limited.


Be sure the flightmode selected is all set with Manual, especially if you set something 'active' (like Rate or AxisLock) in Yaw axis.
This can saturate a motor output as well (at min or max), if you moved the board around his Yaw axis.

What are you trying to do exactly ?
« Last Edit: April 06, 2018, 09:21:14 pm by f5soh »

trust

  • *
  • 24
Re: Mixers not working
« Reply #9 on: April 06, 2018, 09:47:18 pm »
Yes, the flight mode is set to manual. It doesn't seem to matter. Checked the throttle input - its range and neutral seem fine.

We have a VTOL experimental aircraft with 2 motors, one on each wing. In vertical mode the wings point up as do the motors.
I'm trying to get 2 motors that will balance the yaw axis once flight mode is set.
We've had versions of this already working, and flown successfully. Like the X-vert, but very different in some other aspects.

Is there a way to just reinitialize the FC, then just upload the UAV config? Maybe that'll clear it.

f5soh

  • *****
  • 4336
    • LibrePilot
Re: Mixers not working
« Reply #10 on: April 06, 2018, 10:09:44 pm »
Quote
Is there a way to just reinitialize the FC, then just upload the UAV config? Maybe that'll clear it.
Seems like solving a Windows OS :)
You can do a upgrade&Erase or just Erase and reload uav file.

Anyways i do not have the issue you describe and mixers runs as expected.
With full Throttle you should get a output saturation other output simply reducing when you move Yaw to one side.

If you want a Yaw response while running at full Throttle you should:
- reduce the Curve1 to 80 for both motors
- set the Yaw mixer value to -20 for output1 and +20 for output2
So the output do not saturate with full Throttle or full Yaw stick.


trust

  • *
  • 24
Re: Mixers not working
« Reply #11 on: April 06, 2018, 11:24:46 pm »
This last tip did it.
I reduced the yaw values to +/-32, now throttle works over entire range. I noticed yaw input is all the way to one side or max value (issue with another FC not working quite right yet).
How do I do an erase? I don't see it in the menus.

Another issue still is with the unused inputs keeping the FC from arming. In modifying an existing setup several input are not used. I set them to disabled but its still sees them for error conditions. As a get around I leave them assigned, but set the mixer inputs to 0, so theoretically they should not have any affect.
How do I force these off?


Re: Mixers not working
« Reply #12 on: April 07, 2018, 02:58:07 am »
Before erasing, do File->ExportUavFile to save off all settings.

To erase, go to Firmware tab, press Halt, wait a few seconds for Erase to become active, then press Erase, then follow the instructions.

Oops, apparently not right for primary functions:  To disable unused inputs, go to Configuration->Input->RcInput and set the Type to None and the Number to Disabled.
« Last Edit: April 07, 2018, 09:18:32 pm by TheOtherCliff »

f5soh

  • *****
  • 4336
    • LibrePilot
Re: Mixers not working
« Reply #13 on: April 07, 2018, 10:42:44 am »
You cannot disable the inputs not needed by setting Disabled - None or you get a INPUT error because the board assumes the Roll/Pitch control still needed for a Custom frame. Ground frame allow two sticks for control.

One alternative for disabling the input for unused stick is set the min/neutral/max to the same value, so the result of stick input is always 0.



Of course unused sticks have already no effect since you leave the input Roll/Picth rows set as 0 in every Mixer output.
« Last Edit: April 07, 2018, 10:48:06 am by f5soh »

trust

  • *
  • 24
Re: Mixers not working
« Reply #14 on: April 11, 2018, 08:45:50 am »
Thanks for these tips.

Made a lot of progress, nearly there - but now when I test stabilization by rotating the aircraft with the motors running, in any of the stabilized modes, rate, attitude, axislock, one side starts drifting up & the other down.
I compensate with inputs to reset, but it drifts fairly rapidly such that one side is always high.
The compensation direction seems correct - if I rotate the opposite way the motors ramp up or down to stabilize.
In manual mode, the motors both seem balanced, min to max throttle.
But there is this rapid drift I can't get rid of.

Well, fixed it by adjusting the neutral point of the output of the FC feeding the motor mix input. I had to shift the neutral point up about 25 units until the drift went away.