ggrif

  • *
  • 178
Error 2 when compiling
« on: December 17, 2017, 09:54:50 pm »
Finally trying to learn how to compile Next, need a little help please.  Non-coder btw, this is all greek to me!

Followed instructions in the Wiki, tried compiling 16.09 and got this far:

...
C:/msys64/mingw64/bin/python C:/msys64/home/GC/librepilot/make/copy_dependencies.py --dest "C:/msys64/hom                                            e/GC/librepilot/build/librepilot-gcs_release/bin" --files "C:/msys64/mingw64/bin/libopenjp2-7.dll" --excl                                            udes OPENGL32.DLL > "C:/msys64/home/GC/librepilot/build/librepilot-gcs_release/src/libs/osgearth/deps/lib                                            openjp2-7.dll.deps"
mingw32-make[4]: *** No rule to make target 'C:/msys64/mingw64/bin/osgPlugins-3.5.9/mingw_osgdb_earth.dll                                            ', needed by 'C:/msys64/home/GC/librepilot/build/librepilot-gcs_release/lib/librepilot-gcs/osg/osgPlugins                                            -3.5.9/mingw_osgdb_earth.dll'.  Stop.
mingw32-make[4]: Leaving directory 'C:/msys64/home/GC/librepilot/build/librepilot-gcs_release/src/libs/os                                            gearth'
mingw32-make[3]: *** [Makefile:437: sub-osgearth-make_first-ordered] Error 2
mingw32-make[3]: Leaving directory 'C:/msys64/home/GC/librepilot/build/librepilot-gcs_release/src/libs'
mingw32-make[2]: *** [Makefile:44: sub-libs-make_first-ordered] Error 2
mingw32-make[2]: Leaving directory 'C:/msys64/home/GC/librepilot/build/librepilot-gcs_release/src'
mingw32-make[1]: *** [Makefile:43: sub-src-make_first-ordered] Error 2
mingw32-make[1]: Leaving directory 'C:/msys64/home/GC/librepilot/build/librepilot-gcs_release'
mingw32-make: *** [Makefile:308: gcs] Error 2


filnet

  • *****
  • 112
Re: Error 2 when compiling
« Reply #1 on: December 17, 2017, 10:51:09 pm »
next is currently broken on windows because of a msys2 dependency issue.

I'll try to come up with a workaround tomorrow.


ggrif

  • *
  • 178
Re: Error 2 when compiling
« Reply #2 on: December 17, 2017, 10:55:27 pm »
Thanks. But please, no rush or pressure, from me anyway.

At this point this is simply an intellectual exercise for me.

Glad I didn’t just make another mistake!!

filnet

  • *****
  • 112
Re: Error 2 when compiling
« Reply #3 on: December 18, 2017, 08:45:20 pm »
If you disable osg/osgearth GCS should compile fine.

Edit the Makefile at the root of the LP checkout and find the following section:

else ifeq ($(UNAME), Windows)
    UAVOBJGENERATOR := $(BUILD_DIR)/uavobjgenerator/uavobjgenerator.exe
    GCS_WITH_OSG      := 1
    GCS_WITH_OSGEARTH := 1
    GCS_COPY_OSG      := 1
    GCS_WITH_GSTREAMER := 0
    GCS_COPY_GSTREAMER := 0
endif

In there, simply change the 1s into 0s and do a clean build.


ggrif

  • *
  • 178
Re: Error 2 when compiling
« Reply #4 on: December 18, 2017, 10:40:10 pm »
OK, thanks 
I'll see if I can figure out how to do this.  Should be interesting.

filnet

  • *****
  • 112
Re: Error 2 when compiling
« Reply #5 on: December 20, 2017, 09:46:21 am »
Actually, just setting GCS_WITH_OSGEARTH to 0 should be enough.