nabakou

  • *
  • 21
attitude mode problem
« on: October 30, 2015, 11:03:00 am »
hi guys,

cc3D+openpilot mounted on acrobatic plane
manual and rate modes work well
...but in attitude , even with good leveling, the accelerometers shift a lot 4 times on 5, 4 times the plane does anything he wants..the 5th it's perfect
it isn't a problem of vibrations, even on a table with motor off he does that...and i've checked with external 5v regulated, nothing changes

somebody has an idea ?

thanks.. ;)

f5soh

  • *****
  • 4111
    • LibrePilot
Re: attitude mode problem
« Reply #1 on: October 30, 2015, 01:13:13 pm »
Hi Nabakou, welcome :)

Just after you power board, did you wait the Gyro init ?

If not, check the "Zero gyros while arming" for gyro init when airframe do not move.
I assume you don't set a "Always armed" setting.

al

  • *
  • 22
Re: attitude mode problem
« Reply #2 on: October 30, 2015, 02:09:21 pm »
Did you do the "levelling" procedure?
Had a similar effect with my Helicopter tail, after doing the levelling everything was fine,
although flight data had looked good before.
« Last Edit: October 30, 2015, 02:33:37 pm by al »

nabakou

  • *
  • 21
Re: attitude mode problem
« Reply #3 on: October 30, 2015, 05:57:24 pm »
ok folks, thank you for answer

it works....

 leveling was correct , gyros were reset at power up...but there were 2 other problems

1) shifting with motor off, this problem seems to be resolved with "accelerometers filter" set to 0.20

2) i don't understand why but if i connect the cc3D throttle output to the ESC, when the motor turns the ailerons shift a lot
I've tried with an external 5 Volts source to replace the ESC BEC, nothing changes
i've tried with another ESC, nothing changes
i've tried with motor not fixed on the plane to avoid vibrations, nothing changes

finally, i've connected the ESC directly on the RC receiver and nothing on the cc3D motor output....and miracle : all is perfect

flight tests of this afternoon : manual, rate and rattitude ok !

why ?.....don't know...but it flies well !.. 8)

f5soh

  • *****
  • 4111
    • LibrePilot
Re: attitude mode problem
« Reply #4 on: October 30, 2015, 07:02:37 pm »
Great, but i want to know :)

So just disconnect motor from CC3D and connect to Receiver, no config changes ?

Can you post your config file ?
File > Export UAV settings

Thanks.

nabakou

  • *
  • 21
Re: attitude mode problem
« Reply #5 on: October 30, 2015, 09:03:30 pm »
:)
i understand that You want to see some details

there is no config changes, here's the file