Error message when using newest version of Librepilot
« on: October 13, 2017, 09:48:09 pm »
Hi,  this is my question; using windows 10,  downloaded latest version of libre pilot 16.09 ,  attempted to use,  was able to use one time.  Attempted to use again and received error message as follows

  C:\programfiles (x86)Librepilot\bin\Versioninfo.dll is either not designed to run on windows or it contains an error.  Try installation media or contact your system administrator or the software vendor for support
Error status 0xe00000020.

Steps that I have taken:  Removed program and reinstalled with mesa driver,  still had problem
                                      Removed program and reinstalled with all available drivers  still had same problem
                                      Removed program and reinstalled  allowing the default drivers.  Still had same problem.
                                      Power  cycled computer

never had a problem with the previous version 15.09

Thank you in advance.   


f5soh

  • *****
  • 3923
    • LibrePilot
Re: Error message when using newest version of Librepilot
« Reply #1 on: October 13, 2017, 10:04:17 pm »
Hi, welcome.

Remove/uninstall the GCS
Erase the previous dir or install using another installation path.

Re: Error message when using newest version of Librepilot
« Reply #2 on: October 14, 2017, 06:56:22 am »
Thank you for your response but what is the dir ?

f5soh

  • *****
  • 3923
    • LibrePilot
Re: Error message when using newest version of Librepilot
« Reply #3 on: October 14, 2017, 09:11:07 am »
The folder where you installed the GCS

https://www.computerhope.com/issues/ch001320.htm

Re: Error message when using newest version of Librepilot
« Reply #4 on: October 14, 2017, 03:54:53 pm »
And it will usually be either:
     "C:\Program Files (x86)\LibrePilot"
or:
     "C:\Program Files\LibrePilot"

Re: Error message when using newest version of Librepilot
« Reply #5 on: October 14, 2017, 11:27:36 pm »
Thank you,  that solved that problem, you guys all are extremely helpful and I can not thank you enough !
 NEXT PROBLEM:  After program is running and my cc3d board is connected to the computer through the usb port, I use to get a tx  /rx  indication that the cc3d was connected to the computer.   Now I get the error message as follows:

Timed out while waiting for a board to be connected!  You will have to manually upgrade the board with uploader plug in. 

Any clues ?   Is this typically the amount of difficulty that moist newbees have just uploading a program ? 

f5soh

  • *****
  • 3923
    • LibrePilot
Re: Error message when using newest version of Librepilot
« Reply #6 on: October 15, 2017, 01:13:54 am »
Most chinese CC3D boards comes with bootloader v3 so the automatic update do not work.

Update first the bootloader to v4

Next update the firmware using the manual method.