Problems with GCS RELEASE-16.09
« on: July 28, 2017, 08:18:10 am »
Hello.
Sorry for the trouble, but did not find the topic with answers to my questions.
I do not see the "flight data" tab incorrectly. The settings windows merged with the top row of the data display. And this tab is inactive. The data of the PFD are not displayed. What need to do? And one more question: in the yaw channel, the servo operates not to stabilize, but to destabilize. How to fix this in the GCS?

Re: Problems with GCS RELEASE-16.09
« Reply #1 on: July 28, 2017, 08:58:02 am »
The area you circled in red is not for settings, it will display distance traveled and mah consumed from battery if GPS is properly configured and battery sensors are properly configured.  These are rather advanced setups that require additional setup and are usually avoided by beginners...

I am guessing this is an airplane, not a copter.  If that is true, and the airplane has both ailerons and rudder, then it is usually best to set the yaw to manual (not stabilized) or you will be forced to coordinate all your turns whether you want to or not.

Otherwise (but still an airplane): Is yaw stick the correct direction but yaw stabilization backwards?  I think that if the stick controls it correctly and so only the stabilization is backwards, that you reverse both the yaw input reversing check box and the yaw output reversing check box, but I worry that something else is set up strangely, like maybe you have the FC mounted upside down which is best configured a different way.

Re: Problems with GCS RELEASE-16.09
« Reply #2 on: July 28, 2017, 10:55:06 am »
Yes, it's an airplane.
The GPS and battery are configured correctly, but the battery settings are not displayed.
They are displayed only on the glasses screen through the OSD.
The steering of the rudders is adjusted correctly, pitch and roll stabilization works correctly, and on yaw, on the contrary.
Do you recommend turning off yaw stabilization?

f5soh

  • *****
  • 3769
    • LibrePilot
Re: Problems with GCS RELEASE-16.09
« Reply #3 on: July 28, 2017, 12:35:33 pm »
Hi, welcome.

About the PFD display issue, this is a mix between the previous 15.09 and current 16.09.
You need to reset the GCS config with : File > GCS Settings Import/Export > Reset config and close/restart GCS.

Re: Problems with GCS RELEASE-16.09
« Reply #4 on: July 28, 2017, 04:09:41 pm »
I am guessing this is an airplane, not a copter.  If that is true, and the airplane has both ailerons and rudder, then it is usually best to set the yaw to manual (not stabilized) or you will be forced to coordinate all your turns whether you want to or not.

Re: Problems with GCS RELEASE-16.09
« Reply #5 on: July 28, 2017, 06:34:42 pm »
Many thanks for the qualified answers.

Re: Problems with GCS RELEASE-16.09
« Reply #6 on: July 29, 2017, 08:38:54 am »
The interface has been restored. The Revolution's settings have been preserved.
1. Does the "GPS INS13 Navigation" mode apply to all flight modes?
2. In GPS INS13 navigation mode, is the controller armed only with satellites?

I just want to configure the return to base mode. Without it, I'm afraid to fly, because it's a pity to lose the plane.

Re: Problems with GCS RELEASE-16.09
« Reply #7 on: July 29, 2017, 12:38:10 pm »
Yes and Yes.

These are important but less obvious::  Since your airplane has ailerons, use Manual control on yaw for all flight modes.  Never adjust the transmitter trims, or if you do, set them back to neutral and mechanically adjust the linkages on the airplane after you land.

GPS flight modes require good, working, calibrated mags but magnetic hatch hold downs, lipo alarms, and high current motor wiring (twist all thick wires from battery through motor) all produce magnetic fields that distort the mags.  I put a GPS/mag on the tail of my airplane and configured it to use only the aux mag to get it away from all these magnetic things.

Configure GPS/mag and INS13 and get your airplane flying manually, then get it flying with Rate mode, then with Attitude mode, then with (I think) CourseLock, finally test RTB.

For RTB to work well, you will probably have to tune several things (thrust limits, PIDs) in VtolPathFollowerSettings.

Make sure you have RC failsafe and/or FC failsafe set up well enough that it goes into RTB mode at half throttle when you "set the throttle to zero then switch the transmitter off".  Test by (arming, then) going to zero throttle then switching off the transmitter.  Be careful from then on because the motor can start up if it is armed and the transmitter signal is not received for any reason.

Be aware that the stabilization PID "winds up" when flying in Manual mode and when you switch from Manual mode to a stabilized mode it will go crazy for a few seconds.  You can avoid this by moving the throttle to zero before switching from Manual to stabilized or (I recall) by always flying in at least Rate mode.  Rate mode feels like Manual mode if you are used to flying manually and want that feel.

Re: Problems with GCS RELEASE-16.09
« Reply #8 on: July 29, 2017, 01:57:31 pm »
Thank you.
Today I tried to set up the controller on the street. GPS receives 10 ... 12 satellites. When GPS INS13 Navigation is enabled, the controller is not armed. Only when "always armed" is started, the motor starts to be controlled. But Libre Pilot reports an error in arming. After turning off the Libre Pilot, disconnecting the USB and power battery when the controller is switched on again, the controller does not arm itself.
And yet, when switching flight modes on the switching tab, flight mode switching does not happen. They used to switch normally, but now they stopped.
I'm at a dead end. It remains only to use the Revolution as a normal stabilizer. I have been struggling with settings for a long time. But as soon as I reach the return to the base, everything is lost.

Re: Problems with GCS RELEASE-16.09
« Reply #9 on: July 29, 2017, 03:05:21 pm »
Are there errors in the System Health on the Flight Data page?  When you hover mouse over bad color what does it say?

What kind of GPS do you have?

What are you using for mags?  Have you configured your mags, including mag board rotation, use only aux mag?  Did you have a good result from mag calibration?  Is you mag health almost always green and never ever red (sometimes orange)?

Also: go to Configuration -> Input page.  With battery plugged in and USB plugged in you should be able to see every configured control (including flight mode switch and accessory channels) move.  If even a single configured control does not work (including flight mode switch and accessory channels) it must be corrected.

Re: Problems with GCS RELEASE-16.09
« Reply #10 on: July 29, 2017, 06:05:49 pm »
There are no errors on the Flight Data tab. GPS, magnetometer, telemetry are green.
The GPS at my M8N with a connector specially for the Revolution. On the pitch it is carried upwards above the fuselage on the counter. I use a magnetometer on the Revolution board.
Calibration was done according to the instructions. There were no mistakes.
On the "Input" tab everything is beautifully displayed. After setting up the transmitter also did the calibration. All channels, including the mode switch, are displayed and moved. And when switching to the tab "switching flight modes" the engine is in the "stabilization 1" position and does not respond to the transmitter switch.

Re: Problems with GCS RELEASE-16.09
« Reply #11 on: July 30, 2017, 12:03:29 am »
It sounds like your flight mode switch is a problem.  Does the transmitter actually output the FMS switch?  You probably need to set up the transmitter to do something with that switch because the default is nothing.

Re: Problems with GCS RELEASE-16.09
« Reply #12 on: July 30, 2017, 06:26:14 am »
I'll try to assign another switch and go through the tuning of the transmitter in the Libre Pilot again.

Re: Problems with GCS RELEASE-16.09
« Reply #13 on: August 03, 2017, 08:38:24 am »
Set up switching flight modes. Other problems got out. With the GPS attitude estimation algorithm INS13 there is no arming. Servos work, and the motor does not start. Confirmation of arms in Libre Pilot does not happen.
Telemetry data is displayed on the Flight Data tab, and the OSD does not work. In the system section, the OSD setting is inactive. The SDO is configured, used to work.

Re: Problems with GCS RELEASE-16.09
« Reply #14 on: August 03, 2017, 10:33:46 am »
I am not an OSD expert.  Perhaps someone else can give advice.

Does OSD work if you boot without USB?  If it used to work, I would undo recent changes one at a time to see what it takes to get it working again.

Look at FlightData -> SystemHealth at the time you arm.  Everything must be green to arm.  GPS and mags are the usual non-green things for INS13 and are not required to arm Basic.  GPS probably not green indoors and even outdoors you need to wait a few minutes to get a good GPS fix.