andyp

  • *
  • 37
Re: New video gadget
« Reply #90 on: May 25, 2018, 10:43:05 am »
I tried compiling once, but somehow python was missing and I didn't had the time to check this. Result was an error.

I googled a little bit and I found something of using dshowvideosrc device-name="..." instead of ksvideosrc. Not at home at the moment, but will try as soon as possible.

sam028

  • *
  • 38
Re: New video gadget
« Reply #91 on: May 26, 2018, 07:13:33 pm »
And example when things are working well (with video signal loss after the RTB and attitude warnings but that's not the point): .
Well [email protected]!

karla

  • ****
  • 475
Re: New video gadget
« Reply #92 on: July 16, 2018, 09:24:12 am »
After my Win 10 PC did a system upgrade yesterday, the video gadget do not work anymore.
This is the error message (after I press the play/start button):

setting pipeline ksvideosrc device-index=0 ! decodebin ! tee name=t
    t. ! queue ! intervideosink
    t. ! queue ! autovideosink
starting...
StateChange: element pipeline1 changed state from Null to Ready
StateChange: element pipeline1 changed state from Ready to Paused
NewClock : element pipeline1 has new clock GstSystemClock
Error: element ksvideosrc0 sent error event: Internal data flow error. (../../../../gstreamer-1.8.3/libs/gst/base/gstbasesrc.c(2948): gst_base_src_loop (): /GstPipeline:pipeline1/GstKsVideoSrc:ksvideosrc0:
streaming task paused, reason not-negotiated (-4))
Error: element typefind sent error event: Stream doesn't contain enough data. (../../../gstreamer-1.8.3/plugins/elements/gsttypefindelement.c(983): gst_type_find_element_chain_do_typefinding (): /GstPipeline:pipeline1/GstDecodeBin:decodebin0/GstTypeFindElement:typefind:
Can't typefind stream)
StateChange: element pipeline1 changed state from Paused to Ready




I really do not have a clue how to fix it, anyone?

Might add that when using the standard Win Camera app, then the video from the camera on the heli shows just fine.

kind regards
« Last Edit: July 16, 2018, 09:31:19 am by karla »

karla

  • ****
  • 475
Re: New video gadget
« Reply #93 on: August 05, 2018, 03:42:17 am »
I am really happy now.
After some later updates by win 10, the video gadget is working just like before again.
K