karla

  • ****
  • 275
Revolution Nano - FlexIO port set to PPM+Output
« on: July 13, 2017, 07:23:20 am »
Hello, I have probably just missed something obvious,
but I am a bit confused how to configure the Nano board.

There is an option in Hardware config of a Nano: PPM+Output



But there seem to be no option in the documentation covering such option?



Maybe it does not work like this? Or can it. Would be great if it did?
... and Why is the PWM Out column blank?
« Last Edit: July 13, 2017, 07:40:15 am by karla »

f5soh

  • *****
  • 4052
    • LibrePilot
Re: Revolution Nano - FlexIO port set to PPM+Output
« Reply #1 on: July 13, 2017, 11:01:45 am »
Quote
Why is the PWM Out column blank?

Try again :)

karla

  • ****
  • 275
Re: Revolution Nano - FlexIO port set to PPM+Output
« Reply #2 on: July 13, 2017, 12:23:23 pm »
 :)


karla

  • ****
  • 275
Re: Revolution Nano - FlexIO port set to PPM+Output
« Reply #3 on: July 13, 2017, 12:28:55 pm »
Thanks a lot! much more clear.
Just a follow up question about the Analog In -ports ADC 0 to 4
Can I input a battery voltage and current meter to them?

Total nirvana would be if I can do:

Pin 3 = PWM out for a ESC/Motor
Pin 4 = My PPM input from the radio RX
Pin ? = LiPo voltage sensor input
Pin ? = LiPo current sensor input

Too good to be true?
« Last Edit: July 13, 2017, 12:48:44 pm by karla »

mr_w

  • *
  • 151
    • LibrePilot
Re: Revolution Nano - FlexIO port set to PPM+Output
« Reply #4 on: July 14, 2017, 12:01:42 am »
I'd say no, it is not possible to use ADC function if PWM outs are enabled, even if they are not actually in use. That is something that is worth fixing though.


karla

  • ****
  • 275
Re: Revolution Nano - FlexIO port set to PPM+Output
« Reply #5 on: July 14, 2017, 10:05:23 am »
Okay, thanks. I am doing some experiments to find out for sure.

At the moment I cant even get PPM-in to work.
The Health gadgets INPUT has a yellow warning (not alarm) - System is in failsafe mode OR Failed to update or more of the accessory channels.
Is there anything more needs to be done I forgot?
after setting the
. Config, Hardware receiver port to PPM
. Config, Input, Remote control input, specify all the Type to PPM for all the Channels (I use 8 )

The receiver activity field show No activity, what ever controls I move on the TX.

. I know the TX is sending PPM and for all 8 channels (have another vehicle to test).
. I know the Oplink receiver side module is working fine since I receive Telemetery fine. Also know both Main and Flexi works fine.
. I have checked many times that the TX pin from the Oplink receiver is connected to the PPM pin 4 on the FlexIO port in Revo Nano.
Still this warning...
I have tried with 2 separate Nano's and 2 separate Oplink units.

Anyone successfully using PPM on FlexIO on a Nano unit?
« Last Edit: July 14, 2017, 10:30:27 am by karla »

f5soh

  • *****
  • 4052
    • LibrePilot
Re: Revolution Nano - FlexIO port set to PPM+Output
« Reply #6 on: July 14, 2017, 11:57:01 am »
PPM or PPM+Outputs works perfectly here.

Try swapping Flexi/main for PPM out in your Oplink receiver (not coordinator)
« Last Edit: July 14, 2017, 12:03:25 pm by f5soh »

karla

  • ****
  • 275
Re: Revolution Nano - FlexIO port set to PPM+Output
« Reply #7 on: July 14, 2017, 01:37:20 pm »
Great to hear that!

I will swop on the output side as well.
Maybe a cable is broken ...

karla

  • ****
  • 275
Re: Revolution Nano - FlexIO port set to PPM+Output
« Reply #8 on: July 15, 2017, 12:26:01 pm »
O M G, got it all to work!
Fantastic!

Just a follow up question about the Analog In -ports ADC 0 to 4
Can I input a battery voltage and current meter to them?

Total nirvana would be if I can do:

Pin 3 = PWM out for a ESC/Motor
Pin 4 = My PPM input from the radio RX
Pin ? = LiPo voltage sensor input
Pin ? = LiPo current sensor input

Too good to be true?

Sometimes, not often, I get surprised by something overdelivering - this is such a moment :)

This is the configuration:

Pin 3 = PWM out for a ESC/Motor
Pin 4 = My PPM input from the radio RX
Pin 5 = LiPo voltage sensor input (set to ADC3 in the ADC routing)
Pin 6 = LiPo current sensor input (set to ADC4 in the ADC routing )

Receiver port set to PPM+Outputs.

I attached the UAV file if anyone like to try.
This goes into my VTOL project :)