ALM

  • *
  • 45
Bluetooth & osd on a single port - doesn't work
« on: June 26, 2017, 11:54:15 pm »
Connect your Bluetooth as normal, once you have done this ONLY connect the rx of the OSD to the TX cable of your bluetooth-port (creating a y cable)

I did that without success on Revo board connecting to FlexiIO port.
But Bluetooth alone works very well with option PPM+Telemetry.
MWOSD works at the same port with PPM+MSP.
So it looks like they can't work simultaneously because of the protocol difference. Any solution?

f5soh

  • *****
  • 3799
    • LibrePilot
Re: Bluetooth & osd on a single port - doesn't work
« Reply #1 on: June 27, 2017, 12:06:23 am »
No solution since you cannot mix protocols, in your case "MSP" and "Telemetry"

Bluetooth need bidirectionnal link = Tx+Rx
Basic OSD can work simply receiving data

ALM

  • *
  • 45
Re: Bluetooth & osd on a single port - doesn't work
« Reply #2 on: June 27, 2017, 12:51:23 am »
But why then in wiki is described that they can work at one port?

f5soh

  • *****
  • 3799
    • LibrePilot
Re: Bluetooth & osd on a single port - doesn't work
« Reply #3 on: June 27, 2017, 01:14:11 am »
Quote
Optional - connect Bluetooth & osd on a single port
Connect your Bluetooth as normal, once you have done this ONLY connect the rx of the OSD to the TX cable of your bluetooth-port (creating a y cable) ( don't forget your osd still needs power)

Finally, change the Port where the Bluetooth module is attached to "Telemetry".

Is the Wiki saying you can use MSP and Telemetry at same time ?
No.

ALM

  • *
  • 45
Re: Bluetooth & osd on a single port - doesn't work
« Reply #4 on: June 27, 2017, 01:30:21 am »
I think I got it. I need different FW for OSD, correct?

What CONTROLLER SOFTWARE should I choose for reading Telemetry protocol instead of this:

#define LIBREPILOT                // Uncomment this if you are using the latest LibrePilot MSP Module
« Last Edit: June 27, 2017, 01:44:55 am by ALM »

ALM

  • *
  • 45
Re: Bluetooth & osd on a single port - doesn't work
« Reply #5 on: June 27, 2017, 02:14:07 pm »
I've tried all other FW from different projects without success. I would like to ask what FW MinimOSD will work at one port with Bluetooth as described in Wiki?

f5soh

  • *****
  • 3799
    • LibrePilot
Re: Bluetooth & osd on a single port - doesn't work
« Reply #6 on: June 27, 2017, 07:43:17 pm »

ALM

  • *
  • 45
Re: Bluetooth & osd on a single port - doesn't work
« Reply #7 on: June 27, 2017, 07:51:02 pm »
Thanks. I've tried already LP_All_From_Revo1110.hex without success. I've also tried UAVTALK-release from night_ghost for MinimOSD.
I connect TX+RX to Bluetooth and only TX to OSD RX. Bluetooth works fine but OSD doesn't receive any data.
I also use LibrePilot-16.09+r423-g1a4bb0c_i686 FW and FlexiIO port PPM+Telemetry.
I'm stuck here.
What do you mean need some changes for current Next?


f5soh

  • *****
  • 3799
    • LibrePilot
Re: Bluetooth & osd on a single port - doesn't work
« Reply #8 on: June 27, 2017, 07:59:22 pm »
Quote
What do you mean need some changes for current Next?

To be fully working because UAVO changes.
Some functions displayed in OSD can be not responsive due to some UAVO ID that do not match next branch.

This do not causes issues about the OSD/Bluetooth working at same time.

ALM

  • *
  • 45
Re: Bluetooth & osd on a single port - doesn't work
« Reply #9 on: June 27, 2017, 08:01:19 pm »
Got it. So basically the config I've describe should work. I will keep trying.
Thanks. You gave me a hope )))

ALM

  • *
  • 45
Re: Bluetooth & osd on a single port - doesn't work
« Reply #10 on: June 27, 2017, 10:05:35 pm »
It does work! Finally!
It seems only Throttle pos is not working. Didn't check GPS functions yet.