• *
  • 2
Can't connect Revo/OpLink on 2016 MacBook Pro
« on: May 25, 2017, 12:52:09 am »
Hi everyone,
I have read through after being faced with the same issue of not being able to connect my Revo (or old CC3D board, for that matter) to my new 2016 MacBook Pro.
I have tried all suggested steps without success. When connecting to the only Windows computer I have access to, everything works just fine.
I upgraded the firmware to 16.09 via my Windows machine, but the board still does not connect when plugging it into my Mac.
My previous MacBook Pro had no such issues.

The only 'visible' difference is that I have to use a USB-A to USB-C adapter, since that is the only choice I have on the new MacBook.

Since the other thread is about a year old, I am starting this new one to see if anyone else has had the same issue and come up with a solution for it.
I'd really like to be able to take my Mac outside to use with my quad; my Windows box is a desktop.

Appreciate any ideas anyone may have!
Cheers & happy flying,


  • *
  • 2
Re: Can't connect Revo/OpLink on 2016 MacBook Pro
« Reply #1 on: May 25, 2017, 10:35:58 pm »
Replying to my own question with an update: Sometime during my attempts yesterday, my MacBook started to recognize both the Revo as well as my OpLink Mini, but it is not reliable, i.e. sometimes it works, other times it just doesn't auto-connect and doesn't provide a USB option in the drop-down to manually connect.
None of these issues exist with an older MacBook Air. I am starting to suspect either my USB-A to USB-C adapter. I'll get a micro-USB to USB-C cable next and see if that helps.

In any case, I thought I update the question, just in case someone comes across it and has more ideas. 

Re: Can't connect Revo/OpLink on 2016 MacBook Pro
« Reply #2 on: November 20, 2018, 05:57:59 pm »
I know this is an old thread
- did you find a way to connect to your MacBook?

I find myself in the same situation - any help appreciated

Re: Can't connect Revo/OpLink on 2016 MacBook Pro
« Reply #3 on: November 20, 2018, 07:05:55 pm »
Has your board ever worked?  Has your computer ever worked to connect to board?

Be aware that the GCS version must match the board firmware version to connect.

Do the LED lights on the board come on and blink?

First suggestions are usually to try a different USB cable, computer, or FC to find out what works.