Hot motors - invisible oscillation?
« on: September 16, 2017, 11:40:59 pm »
Recently after a longer then usual flight, after landing I noticed that motors 1 and 3 were significantly warmer than 2 and 4.  Could this be an indicator of an invisible oscillation?  It must at least be an indication of inefficiency.  Wouldn't  my battery last longer if all 4 motors consumed equal power?  Does any one have any ideas as to how to troubleshoot this issue or does it even need correction? Of course all the motors, props and ESC's are identical.  LDPower 2312's, 8 x 4.5 props and Flycolor Raptor ESC's, 4s battery.
LJI S380
Revo
4 LDPower 2312 - 960KV
4 FlyColor Raptor 30A
Spektrum SPM4649T
2200 4S1P Battery
8 x 4.5 Props
Round WS2812 RGB
DJI NAZA Clone GPS

Re: Hot motors - invisible oscillation?
« Reply #1 on: September 17, 2017, 12:16:42 am »
Since it's only 1 and 3 (diagonal) it's more likely that your CCW props don't exactly mirror your CW props.  I have also bought motors that turned out to not be matched in KV, which can cause the same issue.

Do you find that hard yaw command one way works better than the other way?

I would use the scopes (ActuatorCommand.Channel) to see if the throttle levels were the same during a smooth hover.

You could also use the same scope to see if you have an oscillation.  I would reduce the FlightTelemetryUpdatePeriod to say 50ms and look for large (>10%?) quick fluctuations.  Ahh, but perhaps you don't have telemetry?

On those motors you might try some 10x4.5 / 10x4.7 props  Oh, 4s.  In that case those 9.4x4.3 props are probably too big.  If I had extra props I would try cutting 1/2 inch off each tip (so 8.4 length) and rebalancing.
« Last Edit: September 17, 2017, 04:22:16 am by TheOtherCliff »

Re: Hot motors - invisible oscillation?
« Reply #2 on: September 17, 2017, 01:26:08 pm »
Thanks, good suggestions.  I will try the scopes and the hard yaws and report back.  I do have permanent telemetry.  I have gone down to 8 X 4.5 props months ago but did not update my profile.  Did it today, sorry.  I agree, 9" is too big for 4S with this motor.
LJI S380
Revo
4 LDPower 2312 - 960KV
4 FlyColor Raptor 30A
Spektrum SPM4649T
2200 4S1P Battery
8 x 4.5 Props
Round WS2812 RGB
DJI NAZA Clone GPS

Re: Hot motors - invisible oscillation?
« Reply #3 on: September 17, 2017, 10:37:36 pm »
OK, I was able to do a log recording of the scope actuator.  Not sure what I'm seeing. Did not seem to have much difference on the channels.  I also tried Yaw Left and Right and they seem equal.  I playback the log file with split screen and actuators on half and controller on the other half.  Flight POS SW. 6 is Stabilized 1 and POS SW. 5 is Position Hold.  That's were the smooth hover was achieved.  I will try reducing the update period and doing it again.
LJI S380
Revo
4 LDPower 2312 - 960KV
4 FlyColor Raptor 30A
Spektrum SPM4649T
2200 4S1P Battery
8 x 4.5 Props
Round WS2812 RGB
DJI NAZA Clone GPS

Re: Hot motors - invisible oscillation?
« Reply #4 on: September 23, 2017, 01:09:55 am »
No problems found when watching scopes...actuators.  Mysteriously, the problem of the hot motors is also gone.  I did find one possible problem.  The telemetry antenna was mounted less than 5 mm from the surface of the #3 ESC and on full power.  I re-located it in case it was affecting the ESC.  This issue is closed.
LJI S380
Revo
4 LDPower 2312 - 960KV
4 FlyColor Raptor 30A
Spektrum SPM4649T
2200 4S1P Battery
8 x 4.5 Props
Round WS2812 RGB
DJI NAZA Clone GPS