Re: Re: TinyPilot F3?
« Reply #15 on: January 14, 2017, 02:55:06 am »
no just activated it under system and restart the board and then it worked for me...
Hardware: F450 Frame--Revolution Board--EMax 2213-935kv--BullTec 30A Opto--5000mAh 3S 30C LiPo--NEO M8N GPS+MAG--Fr Sky Taranis Plus + OPLink Mini
Addon: sj5000x + two axis gimbal + minimosd + eachine VT + easycap
Software: Black Rhino, LP2GO

Re: Re: TinyPilot F3?
« Reply #16 on: January 14, 2017, 03:49:29 am »
bummer, I can get telemetry out of the RX on UART 3(2) but no luck on the input. 

mr_w

  • *
  • 134
    • LibrePilot
Re: Re: TinyPilot F3?
« Reply #17 on: January 14, 2017, 09:46:06 am »
Are you sure about SBUS being on UART1? All the boards I have seen so far had integrated rx connected to UART2.

@DocHardinger do you mean too many different settings, or just saved too many times?

Re: Re: TinyPilot F3?
« Reply #18 on: January 14, 2017, 10:54:19 am »
Dont really know but when i play too lot with different settings...like changing all three stab banks and using them and then hit save the board goes down and for then on i cant save anymore( i need to reflash the board with dfuutil then)...but could be coincidence...first time this happened was when i played with vehicle settings changing motor channels(but before i changed a lot of other stuff)...
Anyway i will activate log for gcs so next time this happen i can give you more details...looks like some kind of memory problem
Hardware: F450 Frame--Revolution Board--EMax 2213-935kv--BullTec 30A Opto--5000mAh 3S 30C LiPo--NEO M8N GPS+MAG--Fr Sky Taranis Plus + OPLink Mini
Addon: sj5000x + two axis gimbal + minimosd + eachine VT + easycap
Software: Black Rhino, LP2GO

mr_w

  • *
  • 134
    • LibrePilot
Re: Re: TinyPilot F3?
« Reply #19 on: January 14, 2017, 11:53:56 am »
EVO board does not have external flash chip, but saves settings on internal mcu flash, which is not all that big, and there could indeed be a problem with free space management. I will hopefully have my full EVO board at Mon/Tue to debug these issues properly.

Re: Re: TinyPilot F3?
« Reply #20 on: January 14, 2017, 07:19:07 pm »
I'm using this board:

http://www.crazepony.com/products/f3-brushed-fc.html

It list the UARTS as 1,2,3 which I assume corresponds to 0,1,2 in the settings.  I have telemetry on uart 3(2) which works fine, and sbus on 2(1) which worked fine in clean flight but not now.    I also tried setting sbus on all the uarts at first.  Still no luck. 

I did hook up my scope to the sbus line and there is information coming from the RX. 

I could try hooking up a ppm or dsm to it.

I haven't seen any issue with saving settings getting corrupted yet.

« Last Edit: January 14, 2017, 07:23:39 pm by jcoffman98 »

mr_w

  • *
  • 134
    • LibrePilot
Re: Re: TinyPilot F3?
« Reply #21 on: January 14, 2017, 08:48:12 pm »
So the sbus receiver you have is standalone? Can you try getting it first to work, to output valid sbus signal, before connecting to fc?

Re: Re: TinyPilot F3?
« Reply #22 on: January 14, 2017, 09:07:03 pm »
Yes indeed its a standalone micro RX.  I have used it before, this quad flew in the current configuration with clean flight.  I can reflash cleanflight and make sure it still works.

mr_w

  • *
  • 134
    • LibrePilot
Re: Re: TinyPilot F3?
« Reply #23 on: January 14, 2017, 09:46:13 pm »
Would be good to see how it works and if you can see the sbus signal there. Also if you can share that cf configuration file here, maybe it could help.

Re: F3 based flight controller firmware support
« Reply #24 on: January 14, 2017, 11:06:53 pm »
Hello,

I reverted to baseflight and was able to see the sbus rx functioning.  Attached is the BF dump for this 90mm quad, this for the makerfire F3 evo brushed with a standalone furious fpv frsky RX. So at least that confirms the hardware is functioning.  *note:  I lied before when I said cleanflight, this one was betaflight.

I decided to try another brushed evo and this time used a banggood F3 evo, with a cheapo banggood frsky sbus micro rx.  I was able to flash it with librepilot and get the sbus working.  I think I have it setup should be flying it soon.
« Last Edit: January 14, 2017, 11:19:11 pm by jcoffman98 »

mr_w

  • *
  • 134
    • LibrePilot
Re: F3 based flight controller firmware support
« Reply #25 on: January 14, 2017, 11:34:06 pm »
@jcoffman98


Ah, there it is

set sbus_inversion = OFF

There is no such setting at the moment in LP. Let me see if I can come up with something just for test.

Re: F3 based flight controller firmware support
« Reply #26 on: January 14, 2017, 11:59:50 pm »
The furious fpv version I have, has a built in inverter, while the cheaper bang good model I used doesn't.  So LP assumes your sbus input is always inverted I guess?

mr_w

  • *
  • 134
    • LibrePilot
Re: F3 based flight controller firmware support
« Reply #27 on: January 15, 2017, 12:05:15 am »
Hmm, well, yes, but for F3 controller inverted or not should not matter as it is just a matter of UART setting - there is no need for external inverted circuit. It could be however that receiver itself is not capable of outputting regular inverted sbus, therefore requires sbus_inversion = OFF

Can you try fetching my latest commit, there should be new SBUSInverted field in HwSettings UAVO. You can try changing it, to see if it makes any difference.

You will need to make gcs again though.


Re: F3 based flight controller firmware support
« Reply #28 on: January 15, 2017, 12:15:40 am »
I had just hard coded it before I saw your message, essentially the same thing you did sans the uavobject; just for a quick test. While testing this it seems something is still not right, it sees activity on channel 9 which there isn't a channel 9, and only the throttle seems to work, the other channels aren't picked up.  I should note this is on a working taranis setup.

Let me back out my hack and pull in yours and test again.

**update:

Ok so I went back and doubled checked what I was doing, and with your changes I noticed the same behavior as when I had just hard coded the UART to not be inverted, which we would expect.  Taking a closer look at it, it appears to think there is activity on channel 9 all the time.  I can see the other channels activate when I move the stick but channel 9 showing up active all the time is messing everything else up, i.e. I can't do receiver setup.  I didn't notice the other channel activity before because it is hard to see the text change in gcs as channel 9 activity dominates everything. 
« Last Edit: January 15, 2017, 08:26:01 am by jcoffman98 »

Re: Re: TinyPilot F3?
« Reply #29 on: January 15, 2017, 05:50:17 am »
But be careful not to change to much settings because after changing to much settings my board wont accept saving anymore...after hit save anywhere, also under settings, the board disconnects and starts again and again and again.......only thing that helps then is to reflash the board ;-)

The best way to fix this is to export settings, erase settings, import settings.  Then it should work (allow more saves) again.