Re: Problems set up Build environment on OS X
« Reply #30 on: January 15, 2017, 03:31:51 pm »
The "ls -lrt" command means list directory long (verbose) with reverse time order so the most recent show last.

Note that for Linux and MacOS we use the forward slash / to separate directory branches, but Microsoft uses the back slash \ to do this.

You could try
  ls -l /dev > before
plug in the FTDI
  ls -l /dev > after
then do this to compare the two files
  diff before after


  • *****
  • 4572
    • LibrePilot
Re: Problems set up Build environment on OS X
« Reply #31 on: January 15, 2017, 03:41:20 pm »
Here i simply use the 'dmesg' command (dmesg - print or control the kernel ring buffer) just after plugin the FTDI.

Code: [Select]
[143411.080560] usb 3-2: new full-speed USB device number 82 using xhci_hcd
[143411.250175] usb 3-2: New USB device found, idVendor=10c4, idProduct=ea60
[143411.250177] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[143411.250178] usb 3-2: Product: CP2102 USB to UART Bridge Controller
[143411.250179] usb 3-2: Manufacturer: Silicon Labs
[143411.250180] usb 3-2: SerialNumber: 0001
[143411.252965] cp210x 3-2:1.0: cp210x converter detected
[143411.253446] usb 3-2: cp210x converter now attached to ttyUSB0
[laurent@new-host LibrePilot]

Anyways the /dev/ttyUSB0 should work first time without check, except if you plug multiples devices. (FTDI i mean)


  • *****
  • 629
Re: Problems set up Build environment on OS X (SOLVED)
« Reply #32 on: January 16, 2017, 08:09:08 am »
Fantastic - Uploading Succeeded!

Code: [Select]
Karls-MacBook-Air-2:librepilot karl$ ./build/uploader_release/OPUploadTool -i -p ./build/firmware/fw_gpsplatinum/fw_gpsplatinum.opfw -t tty.usbserial-AL00C2RJ
OpenPilot serial firmware uploader tool.
Connect the board NOW
SYNC Succeded
Erasing, please wait...
Uploading firmware
Uploading firmware[==================================================] 100%     Firmware Uploading succeeded
Starting uploading description
Uploading firmware[==================================================] 100%     Uploading Succeded!
Karls-MacBook-Air-2:librepilot karl$

Using my second FTDI unit resolved it.
The first one, I have used many times configuring Bluetooth boards with the little OP config executable for Windows. So I assumed it would work on Mac as well. I just have to accept that the Mac do not recognize it or list it at all, using the ‘ls -l /dev’ or ‘dmesg’ commands. But using the other FTDI unit with some 6 pins (only 4 used), then it listed the somewhat unexpected name ‘tty.usbserial-AL00C2RJ’. But it did work. First try.
Now all my GPSv9 are upgraded :))

Thanks sooo much!

Looking back on this, the Problems to set up the Build environment on OSX was solved early, the solution was really to set up a Xcode project first then download the LP code. Then when installing dev tools I had to back down from Next to LP 16.09 that uses a more familiar version Qt 5.6.1 (not 5.6.2), then okay.
Also okay to do my first build, the OPUploaderTool.
Then when actually using the little executable to upgrade the GPSv9, a ComBridge with Revo did not work (a bit better though after having the GCS running) neither with the first FTDI unit but finally with another one. I really do not know the difference between them. Both work but in different environments.

p.s. I will still try to make use of that Linux + OP16.09 ISO file so kindly posted here.

Finally really nice to hear someone have fixed the ‘Jerry save’ bug in the Heli set up!
That should reduce a lot of the confusion for newcomers.