klarix

  • *
  • 3
install on Debian is not working
« on: December 15, 2016, 10:00:18 pm »
Hello,

I'm trying to install librepilot under Linux Debian, but this is not working, I tried to add the repository as documented on the following page : https://librepilot.atlassian.net/wiki/display/LPDOC/Downloads

but I got the following error :

[email protected]:/etc/apt# add-apt-repository ppa:librepilot/release
 Official LibrePilot release PPA
 More info: https://launchpad.net/~librepilot/+archive/ubuntu/release
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keybox '/tmp/tmpf030k_en/pubring.gpg' created
gpg: /tmp/tmpf030k_en/trustdb.gpg: trustdb created
gpg: key BF3FE17C45DC3732: public key "Launchpad PPA for LibrePilot" imported
gpg: Total number processed: 1
gpg:               imported: 1
gpg: no valid OpenPGP data found.
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python3.5/threading.py", line 914, in _bootstrap_inner
    self.run()
  File "/usr/lib/python3.5/threading.py", line 862, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 688, in addkey_func
    func(**kwargs)
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 386, in add_key
    return apsk.add_ppa_signing_key()
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 273, in add_ppa_signing_key
    cleanup(tmp_keyring_dir)
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 234, in cleanup
    shutil.rmtree(tmp_keyring_dir)
  File "/usr/lib/python3.5/shutil.py", line 474, in rmtree
    _rmtree_safe_fd(fd, path, onerror)
  File "/usr/lib/python3.5/shutil.py", line 432, in _rmtree_safe_fd
    onerror(os.unlink, fullname, sys.exc_info())
  File "/usr/lib/python3.5/shutil.py", line 430, in _rmtree_safe_fd
    os.unlink(name, dir_fd=topfd)
FileNotFoundError: [Errno 2] No such file or directory: 'S.gpg-agent.extra'

Am I making something wrong ? Can you help me solve this probably simple problem ?

Many thanks in advance for help :-)

Klarix

f5soh

  • *****
  • 4363
    • LibrePilot
Re: install on Debian is not working
« Reply #1 on: December 15, 2016, 10:27:29 pm »
ppa is only involved for ubuntu OS, and not yet updated as mentioned in download page.

Using Debian, only the Stretch and above can be supported.
I made build yesterday for stretch, try between this two builds:
https://librepilot.atlassian.net/wiki/download/attachments/4128780/librepilot_16.09-0stretch1_amd64.deb
or
https://librepilot.atlassian.net/wiki/download/attachments/4128780/librepilot_16.09-0stretch1_i386.deb

The amd64 works but you can expect crashes because use qt-5.7.1, so just a experimental build.
i386 build looks working fine with supported qt5.6.1

klarix

  • *
  • 3
Re: install on Debian is not working
« Reply #2 on: December 15, 2016, 11:17:56 pm »
Hello,

Many thanks for your answer, I was thinking that I could install the Ubuntu version on Debian as Ubuntu is based on Debian... I was probably a bit naive on that point :-).

I tried to install the package you linked me, but I got a segfault doing so, below the log when I launch it in a console :

[email protected]:~$ librepilot-gcs
Command line ("librepilot-gcs")
Loading system settings from "/usr/share/librepilot-gcs/"
Loading user settings from "/home/klarix/.config/LibrePilot/LibrePilot GCS.xml"
main - system locale: "en_US"
main - GCS locale: "en_US"
main - language: "en_US"
OsgEarth::registerQmlTypes - registering Qml types...
qrc:/welcome/qml/main.qml:106:9: Type CommunityPanel unavailable
qrc:/welcome/qml/CommunityPanel.qml:65:5: Type ActivityPanel unavailable
qrc:/welcome/qml/ActivityPanel.qml:2:1: module "QtQuick.XmlListModel" is not installed
QuickWidgetProxy - status Error
"Type CommunityPanel unavailable"
"Type ActivityPanel unavailable"
"module \"QtQuick.XmlListModel\" is not installed"
Configured style sheet: "default"
Loading style sheet file "/usr/share/librepilot-gcs/stylesheets/default.qss"
Loading style sheet file "/usr/share/librepilot-gcs/stylesheets/default_linux.qss"
UAVGadgetInstanceManager::createOptionsPages - failed to create options page for configuration "TelemetryMonitorGadget:default" , configuration will be removed.
UAVGadgetInstanceManager::createOptionsPages - failed to create options page for configuration "Uploader:default" , configuration will be removed.
PfdQmlGadgetWidget::setQmlFile "/usr/share/librepilot-gcs/qml/Pfd.qml"
PfdQmlGadgetWidget::setQmlFile "/usr/share/librepilot-gcs/qml/Model.qml"
OsgEarth::initialize - initializing osgearth...
[osgEarth]* [CacheFactory] Failed to load cache plugin for type "filesystem"
Segmentation fault

Also I tried to install the deb package for Ubuntu which is provided on the Librepilot website, but I miserably failed to find a working repository for all qt56xxxx packages :-(. Is this a common library ? I got like less than 2 results pages in google when searching for qt56base repository, and almost all were referencing the same repository (ppa:beineri/opt-qt562-trusty), but when adding that repository, I encounter a 404 :'(.

E: Failed to fetch http://ppa.launchpad.net/beineri/opt-qt562-trusty/ubuntu/dists/zesty/main/binary-amd64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Thanks a lot again for the help, and sorry for my noob questions :D,

Klarix

f5soh

  • *****
  • 4363
    • LibrePilot
Re: install on Debian is not working
« Reply #3 on: December 15, 2016, 11:26:53 pm »

You cannot install Ubuntu package under Debian.
Ubuntu is based on Debian but they diverged since some time.

Try installing additional packages:
Code: [Select]
apt-get install  openscenegraph openscenegraph-plugin-osgearth
and maybe others
Code: [Select]
apt-get install qml-module-qtquick-controls qml-module-qtquick-dialogs qml-module-qtquick-xmllistmodel qml-module-qtquick-localstorage qml-module-qtquick-particles2 qml-module-qtquick-window2 qml-module-qtquick2

klarix

  • *
  • 3
Re: install on Debian is not working
« Reply #4 on: December 15, 2016, 11:39:01 pm »
Hey,

"You're just too good to be true" ;-) !

It worked after the first line, at least it's launching, I'll try out tomorrow to setup a CC3D with it, thanks a lot really for the help, you made my day :-) !

PS: Is there any 'official' Debian version foreseen ? Are you interested in getting feedback from problem I could encounter while using the app ?

Klarix

f5soh

  • *****
  • 4363
    • LibrePilot
Re: install on Debian is not working
« Reply #5 on: December 15, 2016, 11:48:04 pm »
Currently the release was designed using qt-5.6.1 and the Debian Stretch hosts the qt-5.7.1
Know Debian issue you can reproduce is open the About window and close. After this it may crash.


f5soh

  • *****
  • 4363
    • LibrePilot
Re: install on Debian is not working
« Reply #7 on: February 02, 2017, 11:00:54 pm »
Simply because i just build manually the package for Klarix and as reported in previous messages the amd64-stretch is not stable.



Re: install on Debian is not working
« Reply #8 on: February 03, 2017, 08:10:39 am »
... stretch is not stable.

But just around the corner. Rc2 is out, full freeze announced for this coming weekend.

Tried to build GCS myself, worked somehow, but I missed an instruction, how to generate a deb package.

Much more convenient.


Thank you anyway ....

Code: [Select]
DEBIAN Stretch

[email protected]:~$ sudo apt-get install build-essential ccache debhelper git-core git-doc flex graphviz bison libudev-dev libusb-1.0-0-dev libsdl1.2-dev python libopenscenegraph-dev qt5-default qttools5-dev-tools libqt5svg5-dev qtdeclarative5-dev qml-module-qtquick-controls libqt5serialport5-dev qtmultimedia5-dev qtscript5-dev libqt5opengl5-dev qml-module-qtquick-controls qml-module-qtquick-dialogs qml-module-qtquick-xmllistmodel qml-module-qtquick-localstorage qml-module-qtquick-particles2 qml-module-qtquick-window2 qml-module-qtquick2 libosgearth-dev openscenegraph-plugin-osgearth

[email protected]:~$ sudo apt-get install libc6-i386
[email protected]:~$ mkdir -p ~/code
[email protected]:~$ cd ~/code
[email protected]:~$ git clone https://bitbucket.org/librepilot/librepilot.git
[email protected]:~$ cd ~/code/librepilot
[email protected]:~$ git checkout next
[email protected]:~$ make gcs
[email protected]:~/code/librepilot/build/librepilot-gcs_release/bin$ ./librepilot-gcs
« Last Edit: February 03, 2017, 09:13:09 am by kalle123 »

f5soh

  • *****
  • 4363
    • LibrePilot
Re: install on Debian is not working
« Reply #9 on: February 03, 2017, 11:09:54 am »
I'm not talking about the "strech" distro but GCS under Stretch not stable.

All needed for local build is described here, same for package:
https://librepilot.atlassian.net/wiki/display/LPDOC/Linux+-+Building+and+Packaging#Linux-BuildingandPackaging-Package


Mateusz

  • *
  • 808
Re: install on Debian is not working
« Reply #10 on: February 03, 2017, 02:39:09 pm »
I am a GNU/Linux Debian user since 1998, and in my opinion both sid and testing (aka stretch) are changing so fast that I wouldn't ever bet package older than 1 month to be compatible. It may, or may not. Personally I prefer to build from source (make package) or use built binary from directory. Just make sure to checkout tag rel-16.09 from git, as next might be work in progress with unknown issues.
Ubuntu is not compatible with Debian and if stuff works, then you're very lucky, but in general you should not mix packages from different distributions. Ubuntu Trusty is LTS (long term support) release, so it's nothing like suddenly they will bump library version breaking lots of dependencies.


Re: install on Debian is not working
« Reply #11 on: February 03, 2017, 07:21:09 pm »
I am a GNU/Linux Debian user since 1998, and in my opinion both sid and testing (aka stretch) are changing so fast that I wouldn't ever bet package older than 1 month to be compatible.

That makes sense.

My desktop at the moment is PCLinuxOS (no chance there with LibrePilot) and have in a vbox arch and DEBIAN stretch.
But as PCLos is aiming to KDE5 and I am NOT going with that, I'll be back with DEBIAN, when stretch is out. Was on DEBIAN before (Wheezy and Jessie).

Might need a hand, when it comes to build the *.deb package. With the command, I posted, managed to get an executable inside that ~/code/librepilot folder for the GCS. But reset the vbox guest after that experiment. At the moment using that deb package from here.




Re: install on Debian is not working
« Reply #12 on: February 08, 2017, 01:00:23 pm »
One issue I found in this how-to for DEBIAN stretch

https://librepilot.atlassian.net/wiki/display/LPDOC/Linux+-+Building+and+Packaging

At that point, I get an error

Quote
[email protected]:~/code/librepilot$ make build_sdk_install
 INSTALL     gcc-arm-none-eabi
Downloading https://launchpad.net/gcc-arm-embedded/4.9/4.9-2015-q2-update/+download/gcc-arm-none-eabi-4_9-2015q2-20150609-linux.tar.bz2
/home/kalle/code/librepilot/tool_install.sh: Zeile 70: curl: Kommando nicht gefunden.
/home/kalle/code/librepilot/tool_install.sh: Zeile 216: downloaded_file ist nicht gesetzt.
/home/kalle/code/librepilot/make/tools.mk:68: die Regel für Ziel „gcc-arm-none-eabi_install“ scheiterte
make: *** [gcc-arm-none-eabi_install] Fehler 1

The package "curl" has to be installed!

f5soh

  • *****
  • 4363
    • LibrePilot
Re: install on Debian is not working
« Reply #13 on: February 08, 2017, 01:19:45 pm »
That not really a issue as long the output tell you the curl command is missing.

Quote
curl: Kommando nicht gefunden
.

Updated wiki page

Re: install on Debian is not working
« Reply #14 on: February 08, 2017, 01:54:29 pm »
Updated wiki page

Thank you, that was my aim.