• *
  • 1
After vehicle setup. Cannot get transmitter to bind
« on: July 18, 2016, 04:55:34 pm »
I was able to successfully get the vehicle setup and all of the motors moving in the correct direction.  After it was complete i moved on to transmitter setup and the controls did not respond.  I am using a DX6 radio with a cc3d board and a specktrum satellite receiver. 
I tried multiple times to bind it manually without success.  I apologize if this topic has been covered before.  I'm new to the quadcopter scene. note, I have tried two different receivers and neither worked. 


  • **
  • 66
Re: After vehicle setup. Cannot get transmitter to bind
« Reply #2 on: July 21, 2016, 03:27:14 am »
I had problems binding a new Spektrum satellite receiver to a DX8 as well.  Couldn't get the get the flight controller to put the satellite into bind mode (flashing light).  Ended up plugging the satellite into an AR8000, binding it the old-fashioned way (binding plug) and then plugging it back into the flight controller.  That worked fine.

I never determined whether this was due to user-error or a bug.