BobbyC

  • *
  • 3
CC3D Atom issue
« on: September 30, 2015, 05:01:45 am »
Hello!

I was directed here by a member on RCGroups.com.

I recently received a cc3d Atom from Banggood and I'm getting a red X over Attitude in GCS.



I searched and most of the guys that have the same problem were on openpilot.org but I can't join and there's no resolution on their threads because the admins (or whoever) went to PM's and haven't updated the threads.

I tried rescuing the Atom about 5 times with a new bootloader (BL v4). I downloaded the bootloader 3 different times in case it was a bad download. I also tried the Altitude calibration in GCS. Nothing seems to work. The only other thing I've read is that it might be that I have a bad gyro on the board.

Anything else I can try? Thanks in advance.

f5soh

  • *****
  • 4363
    • LibrePilot
Re: CC3D Atom issue
« Reply #1 on: September 30, 2015, 09:38:36 am »
Hi,

If you have updated bootloader to v4 and updated/Erased firmware you may have an hardware issue.
Ask for a replacement where you buy.

Be sure you really erased board, this need at least 30s after reboot.

- Disconnect board
- Hit Update&Erase board
- Connect board
- Wait firmware update
- Wait board reboot and erase for 30s
- Board return connected to Gcs

BobbyC

  • *
  • 3
Re: CC3D Atom issue
« Reply #2 on: September 30, 2015, 11:19:10 pm »
Hi,

If you have updated bootloader to v4 and updated/Erased firmware you may have an hardware issue.
Ask for a replacement where you buy.

Be sure you really erased board, this need at least 30s after reboot.

- Disconnect board
- Hit Update&Erase board
- Connect board
- Wait firmware update
- Wait board reboot and erase for 30s
- Board return connected to Gcs

Yep, tried that and it didn't make a difference. I'm trying to get it replaced by BG but they haven't responded yet.

Re: CC3D Atom issue
« Reply #3 on: October 01, 2015, 08:15:53 am »
Hi,

If you have updated bootloader to v4 and updated/Erased firmware you may have an hardware issue.
Ask for a replacement where you buy.

Be sure you really erased board, this need at least 30s after reboot.

- Disconnect board
- Hit Update&Erase board
- Connect board
- Wait firmware update
- Wait board reboot and erase for 30s
- Board return connected to Gcs

Yep, tried that and it didn't make a difference. I'm trying to get it replaced by BG but they haven't responded yet.

They take their time responding and replacing, but it is certainly an hardware issue. Did you email them or left message on forum? Email them the screen shot you posted to [email protected] That will do the job.
Customer FPV Quad Studio
http://ScratchBuilds.com

BobbyC

  • *
  • 3
Re: CC3D Atom issue
« Reply #4 on: October 01, 2015, 08:39:17 am »
They take their time responding and replacing, but it is certainly an hardware issue. Did you email them or left message on forum? Email them the screen shot you posted to [email protected] That will do the job.

They responded and wanted a video so I made one and sent it to them. Apparently, they think their customers are liars and need proof.

Mateusz

  • *
  • 808
Re: CC3D Atom issue
« Reply #5 on: October 01, 2015, 04:31:32 pm »
They responded and wanted a video so I made one and sent it to them. Apparently, they think their customers are liars and need proof.

I think it's a normal procedure, happened to me always when I wanted something, or something was missing at multiple shops both in Europe and China. I am sure they will help afterwards.