Eachine 250 racer multiple problems
« on: May 08, 2016, 06:48:40 pm »
I recently bought an Eachine 250 ARF Racer and am having trouble getting it hooked up to my Taranis Tx and X8R Rx. I am new at this but am an engineer and started with computers in the 1960's.

Here are a few things I have done:

1. Went to FrSky site and installed latest firmware to Taranis. Taranis still shows old firmware version and date! Beats me.

2. Bound Taranis to X8R. I bound the Tx and Rx as D16 CH1-8. LED on Rx goes green when I turn on Taranis so that looks ok.

3. Downloaded Libre Pilot and calibrated ESC's. At least I think I did. They beeped endlessly during the process and I finally stopped and went on to Setup the Transmitter. (The ESC's beep when I power it up and the motors turned like they should. The green light is on steady and the blue light blinks in .8 second intervals)

4. I followed all the LP instructions to set up the transmitter but when I get to the point where you move the throttle to confirm the Tx is working nothing happens. It looks like the Rx is not communicating with the CC3D FC. I am using the PPM cable in slot 8 with no jumpers.

5. So I I performed a Rescue in LP. Checkmark says successful download but now the board is not recognized at all. Green LED is on bright and blue is a fading blink. X8R has power but ESC's do not beep and motors do not twitch when battery is plugged in.

How do I recover from this failed rescue and get the FCB to communicate with the Rx?

Thanks for any help you can give me. This has been a very frustrating three weeks.

hwh

  • *
  • 1018
Re: Eachine 250 racer multiple problems
« Reply #1 on: May 08, 2016, 06:59:02 pm »
...How do I recover from this failed rescue and get the FCB to communicate with the Rx?...

You probably replaced the bootloader but didn't load the main firmware.   With the cc3d disconnected go to the firmware tab and click "upgrade and erase".  Connect the cc3d when it tells you to and it should load the firmware and be recognized again.

edit:  for the receiver problems, after you go through the wizard again if it doesn't work post a copy of your uav config file here.   With the cc3d connected File -> Export UAV file.   That lets us look at all your settings and hopefully see what's wrong.
« Last Edit: May 08, 2016, 07:12:03 pm by hwh »

Re: Eachine 250 racer multiple problems
« Reply #2 on: May 08, 2016, 07:23:21 pm »
When I used Upgrade&Erase LP asked for the file location. I had a hard time finding it since LP did not automatically point to the proper folder. I finally downloaded one from the site which I installed. After that nothing works. Attached is a screen shot as it sits now. None of the buttons are active except for Upgrade and Upgrade&Erase. I thought that LP would have included the correct firmware in the program download but I can't find it if is is there.

f5soh

  • *****
  • 4545
    • LibrePilot
Re: Eachine 250 racer multiple problems
« Reply #3 on: May 08, 2016, 07:31:41 pm »
Yes, no need to download a firwmare from one site you cannot thrust and also a .bin where you should only flash .opfw files

All firmwares are packed inside GCS to avoid mistakes, like the one you did...

Try:
- Disconnect board
- Hit Upgrade&Erase
- Connect board

- Wait until board remain connected, the erase part take maybe 30s


Re: Eachine 250 racer multiple problems
« Reply #4 on: May 08, 2016, 07:38:41 pm »
I did that. The led's light up but the program times out and says the board did not power up and I need to do it manually. What do I do next?

Thanks for your help.

f5soh

  • *****
  • 4545
    • LibrePilot
Re: Eachine 250 racer multiple problems
« Reply #5 on: May 08, 2016, 07:39:45 pm »
Did you disconnect the board before you hit Upgrade&Erase ?

Re: Eachine 250 racer multiple problems
« Reply #6 on: May 08, 2016, 08:18:43 pm »
Yes

Re: Eachine 250 racer multiple problems
« Reply #7 on: May 08, 2016, 08:22:35 pm »
Sorry, i just noticed your edit asking for the uav file which is attached.

f5soh

  • *****
  • 4545
    • LibrePilot
Re: Eachine 250 racer multiple problems
« Reply #8 on: May 08, 2016, 08:25:13 pm »
You say nothing works and you post the config file ?

What you need exactly ?

Re: Eachine 250 racer multiple problems
« Reply #9 on: May 08, 2016, 08:35:38 pm »
I replied to hwh's request above. I need to figure out how to get the proper firmware loaded on the CC3D since LP no longer senses when the power is on.

f5soh

  • *****
  • 4545
    • LibrePilot
Re: Eachine 250 racer multiple problems
« Reply #10 on: May 08, 2016, 08:39:54 pm »
The UAV config you posted is nothing special, all defaults you can find after erase.

What happens after you do a Rescue ?

- Rescue button
- Connect board


Re: Eachine 250 racer multiple problems
« Reply #11 on: May 08, 2016, 08:51:08 pm »
LP times out and says board is not connected, But it is. The green led is bright and the blue one is blinking fast. No other commands are available.

f5soh

  • *****
  • 4545
    • LibrePilot
Re: Eachine 250 racer multiple problems
« Reply #12 on: May 08, 2016, 08:56:34 pm »
If the rescue do not work at all, try another cable.

Rescue works the same as manual update, the board need to be connected after you hit the Rescue button

Re: Eachine 250 racer multiple problems
« Reply #13 on: May 08, 2016, 09:13:32 pm »
There is nothing wrong with the cable. it worked perfectly well until I tried to upgrade the firmware. I had previously calibrated the ESC's and only had trouble getting to the transmitter setup.

I did connect the board after I hit the rescue button. Right now the CC3D is powered but LP in manual mode is waiting for a board to be connected. Rx also has not power.
Nothing works.

f5soh

  • *****
  • 4545
    • LibrePilot
Re: Eachine 250 racer multiple problems
« Reply #14 on: May 08, 2016, 09:20:06 pm »
When you connect the board for rescue, the board should be alone. This means no external power except from the USB connector.
If the rescue do not work, the only solution is programming the bootloader using the mainport.

All is explained here, you need a usbserial :
http://www.southquay3d.com/index.php?route=news/article&news_id=9

I wonder what is the LPFirmwareUpdate4-7.bin you flashed in your screenshot.