LibrePilot Forum

General Category => General Discussion => Topic started by: Francis on June 13, 2018, 07:05:45 pm

Title: Problem with the engines speed
Post by: Francis on June 13, 2018, 07:05:45 pm
Hi! I´m working with my cc3d and an Arduino. I´m using a potentiometers to simulate the radio controllers sticks. I use a 50Hz PWM with a duty from 1 to 2 ms. The neutral is in 1.5ms of duty. The problem that I have is that the cuadcopter stars when you reach over 1500, and with this duty the motors go too fast and I can´t make them go slower. Because if I go down 1500 they turn off. I tried to set the minimum over 1000 but the librepilot doesn´t allow it. It´s the same if I try to lower the maximum. I wanna know how to make them star slow and then regulate their speed. 
Title: Re: Problem with the engines speed
Post by: TheOtherCliff on June 14, 2018, 02:08:01 am
Talking about Min/Neutral/Max.  Throttle/Thrust Neutral on Input page should be about 1040 (as I recall) if Min is 1000.  On Output page, Each motor Neutral should be about 20 (can be less, but this is good) above the speed that that motor starts to spin, so probably about 1080 for several common protocols.

This is your problem.  Correct it and the problem is fixed.  :)
Title: Re: Problem with the engines speed
Post by: Seven5555 on June 19, 2018, 10:06:03 pm
I'm having a similar problem. The motors are stopped when I arm but are full on when I add a little throttle. I'm having this problem with a hex and a quad. The neural point is set right in the output tab. They are at 1065 and gradually speed up but with the transmitter its all or nothing. Its uncontrollable and flips over every time I try to fly.  How do I get it to gradually speed up?
Title: Re: Problem with the engines speed
Post by: TheOtherCliff on June 20, 2018, 12:47:46 am
Both Input and Output pages must be correct.

Throttle/Thrust Neutral on Input page should be about 1040 (as I recall) if Min is 1000.
Title: Re: Problem with the engines speed
Post by: Seven5555 on June 20, 2018, 06:21:18 am
this is what i have.  Please tell me what I need to adjust. I appreciate you help. setup like this, it is full on when i bearly add throttle
Title: Re: Problem with the engines speed
Post by: Seven5555 on June 20, 2018, 06:38:03 am
i adjusted the update rate from 490 down to 270 and same thing. I arm it and as soon as the motors get signal from the throttle, they are full on and it flips over.
Title: Re: Problem with the engines speed
Post by: TheOtherCliff on June 20, 2018, 07:10:32 am
i adjusted the update rate from 490 down to 270 and same thing. I arm it and as soon as the motors get signal from the throttle, they are full on and it flips over.

That is a stabilization issue.  You have one of:
- FC not mounted arrow forward (ESC / servo connection on righthand side)
- Motors / props not in exact direction as pictured on Vehicle page
- Wrong prop somewhere that blows upward, not downward
- ESCs not plugged in the exact order as on Vehicle page NW=#1, NE=#2, SE=#3 SW=#4

Also make sure that Stabilization->ZeroTheIntegral... is ENABLED.

Or you have adjusted something, maybe thinking it was wrong.
Title: Re: Problem with the engines speed
Post by: Seven5555 on June 20, 2018, 06:13:00 pm
ok the props are in the right plases and spinning the correct diurect but the board orientation is wrong. Is there a way to change that without removing it?

also the zero integral box was not checked. will that help with it going full speed when i give a little throttle?

Thank you very much for the  help
Title: Re: Problem with the engines speed
Post by: Seven5555 on June 20, 2018, 08:31:40 pm
ok it flys but it takes off and falls while trying to hover. Like there's no happy medium. I wish I could get it to gradually throttle up and fly level. its way better than it was. thank you.
Title: Re: Problem with the engines speed
Post by: TheOtherCliff on June 21, 2018, 03:19:25 am
Did you set RotateVirtual... to compensate for the board installation rotation?  You must do this.

Falls while trying to hover sounds like a bad or low battery.  LiPos are very susceptible to damage if discharged too much.

Or wrong prop;  What is motor size and KV and what size prop are you using.  For 2212 (stator size) KV1000 motors (very common) you won't go wrong with a 10x4.[57] prop.
Title: Re: Problem with the engines speed
Post by: Seven5555 on June 26, 2018, 07:30:19 pm
I reinstalled the board with arrow pointing forward. I'm not sure what you mean by "Did you set RotateVirtual... to compensate for the board installation rotation?"

The batteries I'm using are new.

It's a Spedix 250 kit with 12amp escs etc. They both are doing the same thing. They  both have pretty much the same CC3d boards motors etc. Heres a pic.

They both go from 0 to 80% when throttled. Should I make a video?
Title: Re: Problem with the engines speed
Post by: Seven5555 on June 26, 2018, 09:39:33 pm
I reset LP to default settings. Erased the board and calibrated my TX and ESC's per the step by step in the wiki.
Started from scratch, I did exactly as I have been instructed from everything I've read here and it still does the same thing.
After arming, I add the slightest bit of throttle and the motors spin up way past what neutral is set to, up to about 80% of the motors full speed.
This is the same problem I've been having with the hex for 3 months now.It has the motors and props going the correct direction along with the correct board orientation.  I really appreciate your help very much but I need some help getting this resolved so these will fly.  I have quite a few of these CC3D boards brand new. Is it possible this isn't fixable?
Title: Re: Problem with the engines speed
Post by: TheOtherCliff on June 26, 2018, 09:56:33 pm
You didn't mention the other things in that post, like the NW ESC must be plugged into position #1, etc.
Title: Re: Problem with the engines speed
Post by: Seven5555 on June 26, 2018, 10:54:22 pm
I was just making the video to show exactly what it has been doing and when I armed it and added throttle, it gradually sped up. I couldn't believe it so i put on the props and went outside and its flying right.
Up until then it would not do that. I even did a quick rehearsal just before starting to record and it went from 0 to 80%, I clicked record and it stopped doing it.
I am speechless. I'm going to re calibrate because it needs a couple of adjustments so hopefully it doesn't go back but that is so strange that I doubt anyone will believe it. 
Title: Re: Problem with the engines speed
Post by: Seven5555 on June 26, 2018, 11:16:15 pm
and of course it's back to doing it again. I am so fed up with this. I cant tell you how many hours I have into this problem. I will gather myself and make a video later. Thank you for everything. I really appreciate your patience with me.
Title: Re: Problem with the engines speed
Post by: TheOtherCliff on June 27, 2018, 04:07:50 am
Bad vibration can do it too.  Do motors act more normally if you take the props off and try it in Rate mode?  Long ago I had vibration problems that I fixed with one of those anti-vibration mounts.  More recently I had a problem where the mount was vibrating only at a certain frequency/RPM and the problem went away when I removed the anti-vibration mount.  I don't use them any more.

If you can hover in Attitude mode, Rate mode is not too much harder.

You still didn't say whether your NW motor is plugged into position #1 (etc.).  Also, you should take off quickly.  As soon as you start the motors, jump up to knee high.  Also a reminder that the default PIDs don't work well with slow (50Hz) ESC protocol.  The solution is to use at least [email protected] or PWMSync.
Title: Re: Problem with the engines speed
Post by: chipskittles on July 28, 2018, 05:02:42 pm
I have had the exact same problems as you.  My motors on a recently acquired "RTF" new to me quad would spin up past full as soon as I touched the throttle.  It flies great now but it had a rough start. 

Try lowering the motor output to 1600(not 1900).  For whatever reason, probably the so-so Gartt motors that came with mine, the quad will oscillate badly if I increase the motor output to 1900.  It's still set to 1600 and I am fine with it, I am not racing after all. 

Also, make sure your artificial horizon is tilting the right way.  It was opposite to what I thought it should have been and was incorrectly making attitude adjustments to change this to look like what i thought it should have been.  Oops.  These two things were keeping my quad from flying with a completely default config.  Instead it would do cartwheels across the yard. 

Of course what has already been said still applies;  badly out of balance props won't help things either.  I had badly balanced props too because they probably got bent up in the box.  This did not end up being my issue but it didn't help things either.